CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   CFX Contour Plots Troubleshooting (http://www.cfd-online.com/Forums/cfx/75280-cfx-contour-plots-troubleshooting.html)

derz April 21, 2010 05:43

CFX Contour Plots Troubleshooting
 
1 Attachment(s)
Hi all,

I have been having some problems in CFD-Post when trying to display contour plots. Attached is an example of the problem I'm getting. As you can see, the plot is not very smooth and there are blotches where there is no colour at all. I have tried changing the computer's display resolution with no effect. I have also tried changing the type of mesh but I ALWAYS get this problem with EVERY contour. I have no problems with streamlines/vector plots it is only these contours that don't display properly. I am running a pretty good graphics card (ATI Radeon 3650). I really am not sure where the problem is...

Has anyone else ever had this problem? Any feedback would be greatly appreciated.

Thanks!

Attesz April 21, 2010 07:56

Is this a contour plot displayed on a plane? have you turned off the plane visibility?

Timon April 21, 2010 08:48

This problem is related to ATI graphics card drivers. I've seen this behaviour as well, but have not been able to fix it.

derz April 21, 2010 12:05

Thanks for your responses.

Yeh I've tried unselecting the Plane, to no avail. The behaviour occurs when contours are displayed on any surface, not just planes.

So it is an ATI graphics card issue huh? That is annoying. Maybe I'll need to install a new graphics card...any recommendations of graphics cards that work well with CFX?

derz April 22, 2010 20:40

hey guys, thought i'd post a little follow up here.

I have figured out if you use "Save Image" in CFX-Post rather than using a screen-capture, then the image that is saved doesn't show the problems mentioned. This is good news for us ATI graphics card users. This is a good enough solution for me!

Nicola Viscanti September 28, 2010 05:13

In order to see correct colors and accurately displayed objects in the 3D Viewer, some combinations of ATI video cards and ATI graphics drivers on Windows XP require that you set the environment variable VIEWER_CACHE_COLORS to 0:

1. Right-click on My Computer and select Properties. The System Properties dialog appears.
2. Click the Advanced tab.
3. Click Environment Variables.
4. Under System variables, click New.
5. In the Variable name field, type: VIEWER_CACHE_COLORS
6. In the Variable value field, type the number: 0
7. Click OK.
8. To verify the setting, open a command window and enter: set

The results should include the line:
VIEWER_CACHE_COLORS=0

This setting will fix problems such as:
Boundary condition markers placed incorrectly or rendered in white.
Regions around the circles are incorrect (rendered as yellow areas marked with blue)
Mesh lines not displayed properly and with dark patches showing.

bye :)

gravis October 4, 2010 07:33

Alternative
 
An alternative fix would be to set the lower limit very close to, but larger than, zero, e.g. 1e-10.

Also, this problem disappeared for me when upgrading from v11 to 12.

SciChic November 21, 2010 11:08

Thanks Nicola..!!
 
I've been having this problem since few months. As soon as I started working on our new desktop with ATI graphic card, I could never get a smooth velocity/temperature profile. I was blaming my mesh or solver for the issue. Thank you so much Nicola..!!


All times are GMT -4. The time now is 00:29.