CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   Using pt_erosion.F (http://www.cfd-online.com/Forums/cfx/75965-using-pt_erosion-f.html)

Rez May 10, 2010 17:45

Using pt_erosion.F
 
Hello Friends,

I'm trying to use the pt_erosion.F supplied by Ansys in ...CFX/examples/UserFortran to customize the erosion model; however, even after loading the pt_erosion.ccl (provided by Ansys in the same directory), the solver crashes. I have compiled the pt_erosion.F with Intel Fortran 10.1 running on IA-32 and the pt_erosion.dll gets generated. So I don't really know what the problem is. It would be greatly appreciated if you can send me some insights into this. the solver error message is:

****** PROBLEM REPORT ****** |
|--------------------------------------------------------------------|
| Subsystem: Input |
| Subroutine name: ErrAction |
| Severity level: Fatal Error |
| Error message number: 001100279 |
|--------------------------------------------------------------------|
| Message: |
| |
| Unable to load symbol pt_erosion from ..\winnt\pt_erosion.dll: Th- |
| e specified procedure could not be found.
|
| |
| |
| |
| |
+================================================= ===================+

+================================================= ===================+
| ****** PROBLEM REPORT ****** |
|--------------------------------------------------------------------|
| Subsystem: Input |
| Subroutine name: ErrAction |
| Severity level: Fatal Error |
| Error message number: 001100279 |
|--------------------------------------------------------------------|
| Message: |
| |
| USER ROUTINE: myerosion could not be loaded. Please check the Lib- |
| rary Path, Library Name and Calling Name. For FORTRAN user routin- |
| es, the Calling Name should be in lower case. |
| |
| |
| |
+================================================= ===================+

+================================================= ===================+
| ****** PROBLEM REPORT ****** |
|--------------------------------------------------------------------|
| Subsystem: Input |
| Subroutine name: ErrAction |
| Severity level: Fatal Error |
| Error message number: 001100279 |
|--------------------------------------------------------------------|
| Message: |
| |
| Stopped in routine UR_REGISTER |
| |
| |
| |
| |
| |
+================================================= ===================+

+--------------------------------------------------------------------+
| An error has occurred in cfx5solve: |
| |
| The ANSYS CFX solver exited with return code 1. No results file |
| has been created.

alinik December 19, 2013 15:44

Hey,

were you able to resolve this issue?

Thanks

HLo December 22, 2013 05:48

uppercase
 
Hello,
the subroutine name must be LOWERCASE in ccl but UPPERCASE in fortran code. Strange, undocumented but that's fact. It is one of the issues when compiling with Mingw's gfortran, as this compiles all subroutine names to lowercase.
See: http://www.cfd-online.com/Forums/cfx...nnt_amd64.html
HLo

meow October 7, 2014 22:12

help me,please
 
hello my friend, I come up with the same trouble like you(forgive my suck English, I'm from China).I build a particle user routain and everything seems well until I run the CFX solver,then the problem report appears.Have you figured it out?or anybody who can help me!!!!Very Very appreciate

HLo October 9, 2014 05:52

Path issue?
 
Creation of dll does not mean it is going to work. ;-(
Input files seem to be correct.
Most common mistake: path to dll wrong: Where does the given "Library Path = .." really point to?
Try a full path to the dll in ccl or CFX-UI first. Later try to adjust to relative path (might differ if CFX is run standalone or from workbench).
If this doesn't help:
Compilation with "cfx5mkext"?
Architectures fit?
Precision settings fit (single, double) in compilaton and solver run?


All times are GMT -4. The time now is 07:39.