CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

1:1 mesh connection

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 28, 2010, 05:58
Default 1:1 mesh connection
  #1
Senior Member
 
Join Date: Jan 2010
Posts: 110
Rep Power: 7
antonio is on a distinguished road
Hi all.

I am modeling a rectangular channel with a smooth bed. At the sides of my channel I am using periodic boundary conditions (translational). When I try to run the solver I receive a message saying that I don`t have enough memory.I think thats caused because the mesh connection is not 1:1 in these faces.Does anyone know how can I do an 1:1 mesh?How can I control this when I do the mesh? I am using workbench to do the mesh

Regards.
antonio is offline   Reply With Quote

Old   May 28, 2010, 06:24
Default
  #2
New Member
 
Join Date: May 2010
Posts: 24
Rep Power: 7
Max Efficiency is on a distinguished road
For 1:1 mesh you have to use the "match control".

But the message "Not enough memory" normally means, that your mesh is too big. Try to mesh your channel with less elements.

When starting the solver take a look at the protocoll on the right side. There you can find a passage similar to that:
" +--------------------------------------------------------------------+
| Memory Allocated for Run (Actual usage may be less) |
+--------------------------------------------------------------------+
Data Type Kwords Words/Node Words/Elem Kbytes Bytes/Node

Real 58222.3 325.81 110.09 454862.0 2606.47
Integer 20671.0 115.67 39.09 80746.2 462.70
Character 3609.7 20.20 6.83 3525.1 20.20
Logical 65.0 0.36 0.12 253.9 1.45
Double 8.0 0.04 0.02 62.5 0.36"

In my case the run needs round about 455 Megabyte RAM. Somewhere around 2000 Megabyte there is a limit. When your mehs is bigger than circa 2000 you have to decrease mesh size or change from a 32-bit-system to a 64-bit-system.
Max Efficiency is offline   Reply With Quote

Old   May 28, 2010, 07:31
Default
  #3
Senior Member
 
Join Date: Jan 2010
Posts: 110
Rep Power: 7
antonio is on a distinguished road
Hi.
Thanks for the reply.
Ill try to use "match control" and then I`ll give you news.
I really believe the problem is caused by the mesh connection because I have already used meshes with more elements than at the present moment. Also in the solver`s manager documentation it says "Each GGI connection means approximately 5% more CPU time and memory is required"...
antonio is offline   Reply With Quote

Old   May 28, 2010, 08:02
Default
  #4
Super Moderator
 
Glenn Horrocks
Join Date: Mar 2009
Location: Sydney, Australia
Posts: 10,671
Rep Power: 84
ghorrocks has a spectacular aura aboutghorrocks has a spectacular aura aboutghorrocks has a spectacular aura about
Yes, a GGI will add a small amount to memory requirements. But if you are so close to filling your memory so that adding a GGI means you exceed memory then you are sailing pretty close to the wind. Alternately, a simulation which is only slightly in excess of available memory should run with a small amount of swap/page file use and still run OK.

I think you have more fundamental problems with your simulation. GGIs sometimes go wrong and gobble up lots of memory. This can happen when the GGI surface is complex or poorly defined. Either that or you mesh or physics is simply too big as Mr Max suggested.
ghorrocks is offline   Reply With Quote

Old   June 1, 2010, 10:53
Default
  #5
Senior Member
 
Join Date: Jan 2010
Posts: 110
Rep Power: 7
antonio is on a distinguished road
Hi all.

I am trying to use the feature "match control" but I am not having success at the present moment. Basically I have a rectangular channel divided in four bodies (in design modeler I have drew a rectangle in a plane formed from an XY plane with an inclination of "alfa" and then extruded it).

Could someone explain with some detail how to use "match control" feature?
antonio is offline   Reply With Quote

Old   June 1, 2010, 11:16
Default
  #6
Member
 
Join Date: Mar 2009
Posts: 44
Rep Power: 8
Timon is on a distinguished road
It's easier to impose symmetry in the symmetry node, which allows you to insert symmetric or periodic faces.
Timon is offline   Reply With Quote

Old   June 1, 2010, 13:59
Default
  #7
Senior Member
 
Join Date: Jan 2010
Posts: 110
Rep Power: 7
antonio is on a distinguished road
Thanks a lot for the reply, but I am also not being able to use this option Symmetry and I really don`t know why.

First I have selected the four faces for the periodic Low and then I did the same for the other four faces (periodic high).But when I want to select a coordinate system something is wrong because the software doesn`t allow me to chose any coordinate system. Do you know why is this happening?
antonio is offline   Reply With Quote

Old   June 1, 2010, 23:10
Default Hi
  #8
Member
 
Dynampally Pavitran
Join Date: Mar 2010
Location: India
Posts: 73
Rep Power: 7
pavitran is on a distinguished road
Quote:
Originally Posted by antonio View Post
Hi.
Thanks for the reply.
Ill try to use "match control" and then I`ll give you news.
I really believe the problem is caused by the mesh connection because I have already used meshes with more elements than at the present moment. Also in the solver`s manager documentation it says "Each GGI connection means approximately 5% more CPU time and memory is required"...
1. Did you use meshes with more elements for the same rectangular channel case? if yes how was the mesh connection then?

2. solver message "Not enough memory", does it prompt something like below:
+--------------------------------------------------------------------+
| ERROR #008100005 has occurred in subroutine LINSOL. |
| Message: |
| Trying to allocate memory, but there is not enough storage left of |
| the required type. Try again with a larger storage multiplier |
| set in the Define Run form in the Solver Manager, e.g. 1.1. |
| Memory partition name = SIWK |
| Memory partition type = 2 INTEGER |
+--------------------------------------------------------------------
pavitran is offline   Reply With Quote

Old   June 2, 2010, 03:55
Default
  #9
Member
 
Join Date: Mar 2009
Posts: 44
Rep Power: 8
Timon is on a distinguished road
Quote:
Originally Posted by antonio View Post
Thanks a lot for the reply, but I am also not being able to use this option Symmetry and I really don`t know why.

First I have selected the four faces for the periodic Low and then I did the same for the other four faces (periodic high).But when I want to select a coordinate system something is wrong because the software doesn`t allow me to chose any coordinate system. Do you know why is this happening?
You first have to create the appropriate coordinate system in the "coordinate systems" node. Then you can choose that cs in the symmetry node.
Timon is offline   Reply With Quote

Old   June 2, 2010, 09:01
Default
  #10
Senior Member
 
Join Date: Jan 2010
Posts: 110
Rep Power: 7
antonio is on a distinguished road
The error says:

ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| The intersection algorithm runs out of memory. Please run again w- |
| ith increased memory settings.

Yes I have already did a simulation with more elements but the length of the channel was smaller than now.

Timon I have already created the coordinate system but the softaware doesn`t "allow" me to use it...
antonio is offline   Reply With Quote

Old   June 7, 2010, 05:40
Default
  #11
Senior Member
 
Join Date: Jan 2010
Posts: 110
Rep Power: 7
antonio is on a distinguished road
Hi all.

I have already managed to solve my problem. I only needed to adjust the memory allocation factor. I have also managed to use match control feature but i couln`t use the symmetry because the software didn`t allowed me to do use a plane created by me.

Thanks to all.Regards
antonio is offline   Reply With Quote

Old   June 7, 2010, 06:11
Default Hi antonio
  #12
Member
 
Dynampally Pavitran
Join Date: Mar 2010
Location: India
Posts: 73
Rep Power: 7
pavitran is on a distinguished road
Quote:
Originally Posted by antonio View Post
Hi all.

I have already managed to solve my problem. I only needed to adjust the memory allocation factor. I have also managed to use match control feature but i couln`t use the symmetry because the software didn`t allowed me to do use a plane created by me.

Thanks to all.Regards
I had similar problems?

1. Increasing memory allocation factor solved my problem.

2. Also by changing to double precision by keeping default memory allocation factor also helped me in running my case.

if you have run the case with single precision, try changing it to double precision without changing the memory allocation factor.
pavitran is offline   Reply With Quote

Old   June 7, 2010, 06:22
Default
  #13
Senior Member
 
Join Date: Jan 2010
Posts: 110
Rep Power: 7
antonio is on a distinguished road
I have also tried that with no results.
Increasing the memory allocation factor was the only way in order to the solver compute the solution.

Regards.
antonio is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
3D Hybrid Mesh Errors DarrenC ANSYS Meshing & Geometry 11 August 5, 2013 06:42
[ICEM] Generating Mesh for STL Car in Windtunnel Simulation tommymoose ANSYS Meshing & Geometry 48 April 15, 2013 04:24
2d irregular grid Remy Main CFD Forum 1 December 22, 2008 05:49
fluent add additional zones for the mesh file SSL FLUENT 2 January 26, 2008 12:55
basic of mesh refinement arya CFX 4 June 19, 2007 12:21


All times are GMT -4. The time now is 01:33.