CFD Online Discussion Forums

CFD Online Discussion Forums (
-   CFX (
-   -   Problems evaluating HeatFlux (

mak86 September 11, 2010 12:14

Problems evaluating HeatFlux
Dear all,
I have modelled a conjugate heat transfer problem. Results and temperature field seem to be ok but when I try to define the heat flux through areas by defining an expression I get zero value.
I use the following expression:
ave(Heat Flux)@targetarea
What is the problem?
Another problem is that the monitor points defined in the CFX-Pre does not appear in the CFD-Post. what should I do to fix this?

ghorrocks September 11, 2010 21:41

You should use the areaAve() function, not the ave function. The ave function just does an arithmetic average of the nodal values with no regard to the element size.

Are you talking about a heat flux on a wall or in the middle of the flow?

Monitor points do not get transferred to CFD-Post. You have to define them again as points in CFD-Post.

mak86 September 12, 2010 03:15

thanks, I have tried the areaAve but I got the same result. I'm trying to evaluate the heat flux at fluid-solid interface. Thanks again

ghorrocks September 13, 2010 06:50

The ave() and areaAve() functions will only return the same value if the mesh size is constant. You should use the correct areaAve() function so if in future you move to graded meshes you calculations will be correct.

I think the variable you are looking for is Wall Heat Transfer.

mak86 September 13, 2010 08:17

I searched the variable list but there is no Wall Heat Transfer variable.

All times are GMT -4. The time now is 17:12.