CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

function calculator gives wrong result in post

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 7, 2011, 12:55
Default function calculator gives wrong result in post
  #1
New Member
 
Join Date: Dec 2010
Posts: 26
Rep Power: 7
mullenc525 is on a distinguished road
Hi,

I'm trying to track down a couple issues and I'm wondering if anybody might have seen something similar.

I'm modelling several ducts with slightly different internal geometry (to improve heat transfer). The CFX-Pre settings are identical, with a moderate heat flux on one duct wall, and a developed inlet temperature and velocity profile.

First, when I use the function calculator in CFX post to measure the average inlet temperature, it is off by 1.441K. The mesh is fine enough to numerically approximate the function much better than that. No ideas what is going on here!

The second issue I have is some of the ducts gain a couple K as expected along their length from the heat flux, but with a different geometry the temperature is decreased at the outlet! I am using an opening BC with the opening temperature as the average of the temperature at the opening. There is insignificant backflow in all geometries so I could probably change this to an outlet.

I am using thermal energy without viscous dissipation (10m/s speeds means viscous heating effects are small). Laminar flow, air ideal gas. The duct is a rectangular prism. The inlet is adjacent to the side with the wall flux, and opposite the outlet. The other sides are symmetrical or adiabatic without slip.
mullenc525 is offline   Reply With Quote

Old   January 7, 2011, 13:54
Default
  #2
New Member
 
Join Date: Dec 2010
Posts: 26
Rep Power: 7
mullenc525 is on a distinguished road
I got the first part, I was using average when I should have been using area average. Also, to do control volume calculations I need to use massflow average of temperature.
mullenc525 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile problem ivanyao OpenFOAM Running, Solving & CFD 1 October 12, 2012 09:31
Can anybody help me to solve the list errors while compiling Openfoam 15 on Opensuse 103 32bit coompressor OpenFOAM Installation 0 November 12, 2008 20:53
Wrong result with bilinear interpolation zonexo Main CFD Forum 1 June 12, 2007 15:55
laminar pipe flow? Fluent gives wrong result SAM FLUENT 2 November 5, 2004 02:39
Wall Function - Correct me if I am wrong Danny Tandra Main CFD Forum 10 July 16, 2003 13:26


All times are GMT -4. The time now is 10:00.