CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CFX

Problem Importing Geometry ProE to CFX

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 23, 2011, 21:31
Default Problem Importing Geometry ProE to CFX
  #1
New Member
 
David Stuart
Join Date: May 2010
Location: Newcaslte Australia
Posts: 15
Rep Power: 6
fatb0y is on a distinguished road
Hi All,

Im having some problems importing geometry into CFX. This is ina way related to a problem I had a while ago for which I stared a thread.

Problematic Geometry

The solution to the problem outlined in that thread was the feature accuracy tolerance of Pro Engineer. That is the minimum accuracy for feature aspect ratio. By lowering the value (ie making accuracy greater) it solved my problematic geometry issues...

If you flick through that previous thread, you'll see that I actually had obvious problems forming the cavity pocket cut out (removing wing from fluid domain part) within proE BEFORE importing into CFX.

I am now working with a similar problem, however the aspect ratio of parts is a little lager, requiring an even smaller greater accuracy (smaller value for lower Accuracy bound) for ProE to sucessfuly create a cut out part for import into CFX. The geometry is happy to sit in the geometry "box" within workbench having been imported via ProE/ANSYS link. However when attempting to mesh within CFX the mesher crashes while "importing" the geomerty and the following error msg is diplayed in workbench...

"Error! Unable to attach Geometry fil (filename). Unable to attach Geometry"

"Warning! (partname): Skipping import of mixed dimension multibody part. Modify mixed import resolution if import is desired"

I've tried this a number of ways and get the same warning. I also tried to import by first saving the Geometry as a parasolid from ProE and this did import. However it did not import the geometry correctly - rather than having a hollow body within a solid fluid domain it was only the curves defining the exterior of the body and higlighted red portioned outlining my old friend problematic geometry.

Out of curiosity, I attempted to open the Geometry in DM to see what it looked like in there. I get nothing, and on the feature tree on the left it says "0 Parts, 0 Bodies" next to the display Model icon...

I've also tried meshing in ICEM. This produced a mesh fine (just using tet/mixed volume mesh as in the sphere cube tutorial with different mesh size values - yes im only learning ICEM!). This however did not solve - The error msg displayed in the Monitor points window says there are isolated fluid regions found.

I do want to add that I am trying the ICEM road again as I type this, I have started from scratch and remade the geometry that im using in ICEM so I'll see how that goes...

So basically Im not sure what Im asking help with because Im not exactly sure where the problem is! The model of the aircraft im looking to simulate looks fine in proE other than the aspect ratio of some features requires the part accuracy to be increased when creating the cutout of the domain part. the mixed dimension message I get in workbench led me to the "import resolution" help file in ANSYS help, but im not sure if the problem is on CAD side or ANSYS side.

If anyone has ever had this sort of issue, any ideas for me to look at will be a big help! If theres anything that I can give more detail on, please let me know. Again anything will help this problem has held me up for a good few days now and I've just about run out of ideas!

Thanks,
Dave
fatb0y is offline   Reply With Quote

Old   January 26, 2011, 23:31
Default
  #2
Member
 
Join Date: Feb 2010
Location: Australia
Posts: 65
Rep Power: 6
RossFS is on a distinguished road
So I take it your ProE model is an assembly?
If so, could the second error message you are getting be due to the units/dimensions being used on one of the parts of the assembly being in different units/dimensions to the rest?
RossFS is offline   Reply With Quote

Old   January 27, 2011, 00:02
Default
  #3
New Member
 
David Stuart
Join Date: May 2010
Location: Newcaslte Australia
Posts: 15
Rep Power: 6
fatb0y is on a distinguished road
Hi Ross,

Yeah its an assembly of the part I want to simulate flow over and a fluid domain around it. Then from there I make a cavity pocket cut out from mold applications which forms the geomertry to mesh.

I dont think that the dimension problem is because of this, both parts are made on teh same machine at the same time so what ever settings are used to make one are the same for the other. I am convinced it is more to do with the aspect ratio of some of the features within the wing model...
fatb0y is offline   Reply With Quote

Old   January 14, 2012, 20:42
Default
  #4
New Member
 
timw
Join Date: Jan 2012
Posts: 1
Rep Power: 0
wong@alfred.edu is on a distinguished road
David,

I don't know if you have figured it out, but when I got the same import error in Ansys Workbench, I was able to get around the problem by going into the original CAD file, "knit"-ting the bounding surface around the geometry in concern, and making it a solid.

Evidently, there were some gaps between surfaces that fell out of tolerances in the import process.

Tim

p.s. The knitting in my case was done via SolidWorks (Mold Tools-->Knit Surface-->Selections (highlight all boundary surfaces)-->"Try to form solid")
wong@alfred.edu is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ansys Workbench (CFX) bucket problem njsavage CFX 1 April 30, 2009 10:51
Urgent Problem with Hypermesh and CFX Luk CFX 5 March 14, 2008 06:59
problem with importing and exporting profile BC Gui CFX 2 July 26, 2007 09:50
CFX Mesh problem Atit Koonsrisuk CFX 4 October 5, 2004 09:14
problem about Importing geometry in Gambit Hua Gu FLUENT 3 April 2, 2002 14:24


All times are GMT -4. The time now is 12:25.