CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   Error in CFX Run (http://www.cfd-online.com/Forums/cfx/91490-error-cfx-run.html)

safikhani_hamed August 12, 2011 06:23

Error in CFX Run
 
Dear friends,
I am doing a simulation in CFX but the software show an error and stop the simulation. In fact I have changed the mesh quality and the boundary conditions but the software do errors for all mesh quality and BCs. The error message is as follows:

| |
| The ANSYS CFX solver exited with return code 1. No results file |
| has been created. |
+--------------------------------------------------------------------+

End of solution stage.

+--------------------------------------------------------------------+
| Warning! |
| |
| The ANSYS CFX Solver has written a crash recovery file. This file |
| has been saved as D:\Thesis\CFX Runs\3D-CFX\Coarse |
| Mesh\Coarse3_002.res.err and may be an aid to diagnosing the |
| problem or restarting the run. More details should be available |
| in the solver output section of the output file. |
+--------------------------------------------------------------------+
Please help me to solve this problem.

ghorrocks August 12, 2011 07:25

Need more details. Please attach an output file. Don't put it on the forum as text directly, just as an attachment.

safikhani_hamed August 12, 2011 08:30

1 Attachment(s)
Dear glenn,
The *.out file is attached.

Sincerely

sajad_abasi August 12, 2011 08:39

hi
read about GET_GVAR in cfx documentation.

safikhani_hamed August 12, 2011 09:42

Dear Sajjad,
Are you sure there is relation between my problem and " GET_GVAR" ? Could you please tell some explanations ? In fact I have searched the CFX help but I did not find any thig about " GET_GVAR" ?

Sincerely

sajad_abasi August 12, 2011 11:20

hi hamed
 
im not sure about your prob and "GET_GVAR" .

but i know that there is a subroutine in cfx that is exactly in this name.

the subroutine "GET_GVAR" get the gradiant of the variable that you define for the software.

you can find more about it in "user fortran routine"

i hope i made it clear for you.

ghorrocks August 13, 2011 07:16

Are you using user fortran?

If not, then remove the physics one at a time until the cause of the problem is obvious. You have probably missed setting something on the multiphase setup, so delete the particle stuff and see if the error still occurs.

juliom August 16, 2011 08:46

I read your .out file, Are you using the discrete model (lagrange model), I suggest you to use Global Dynamic control model and then select the option multiphase.
Besides, You should let ansys to choose the Initial value, change it for automatic.

safikhani_hamed August 16, 2011 14:06

Dear Glenn,
In fact I am trying on this problem for a week , in fact when I delete the solid phase the problem does not occurs but when I add solid phase an error occurs, I do not know what is the problem, could you please help me on this problem?

ghorrocks August 16, 2011 18:46

So that confirms the problem is with your solid phase setup.

I note the size of your particles is nanometers. Are you sure you will get any slip at all with such fine particles? If you are not going to get slip then that simplifies things a lot. And how do the particles interact with the flow? Do they affect the flow at all? How?

safikhani_hamed August 16, 2011 20:39

Dear Glenn,
In fact as mentioned in the CFX help, I define " free slip wall" for solid phase but it also errors, moreover this problem does not related to nano sized particle because when I change the size of particle to mm size also this problem occurs.

sincerely

ghorrocks August 17, 2011 18:31

You have not addressed my question. Quite simply, if there is no slip between the phases because the size of the particles is so small then you do not need a multiphase approach and this will simplify the setup a great deal.

Do you expect significant slip between the phases?


All times are GMT -4. The time now is 02:52.