CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   another issue about HPC cluster for running cfx, hepl PLZ. (http://www.cfd-online.com/Forums/cfx/98160-another-issue-about-hpc-cluster-running-cfx-hepl-plz.html)

happy March 4, 2012 21:12

another issue about HPC cluster for running cfx, hepl PLZ.
 
Hi there
I'm now running ANSYS-CFX simulation via HPC cluster at my Uni.
I used script file with the below command:
cfx5solve -batch -double -def 2cmsteady.def -fullname 2cmsteady -monitor 2cmsteady.res -part $nnodes -par-local

But, when I went through the out file, I found this words which means that double precision not active!!!:(
+--------------------------------------------------------------------+ | |
| CFX Command Language Upgrade
|
+-------------------------------------------------------------------- Added /SIMULATION CONTROL/EXECUTION CONTROL/EXECUTABLE SELECTION/Double Precision = Off.
+--------------------------------------------------------------------+
| |
| CFX Command Language for Run
| |
+--------------------------------------------------------------------
As well as, I run the same simulation on my own PC, and there is different between the resdual for both. So how I can run my simulation via hpc cluster with double precision to avoid run-off error!!!
Finally, if I misunderstand any thing, please, tell me the meaning of this Double Precision = Off.
Regards

ghorrocks March 4, 2012 23:33

I thought that setting double precision at the commend line over-rode any setting from CFX-Pre but your comment suggests this is not so. In that case I would open it in CFX-Pre and toggle th double precision to on.

happy March 4, 2012 23:56

need help
 
Quote:

Originally Posted by ghorrocks (Post 347617)
I thought that setting double precision at the commend line over-rode any setting from CFX-Pre but your comment suggests this is not so. In that case I would open it in CFX-Pre and toggle th double precision to on.

You mean I should open cfx-pre at my own computer and select double precision before I load the def file to my hpc cluster? if this is what you mean, I did it but it did not work.
And if you mean that I should open my .cfx file via hpc cluster, that what I did not and I do not know to control it. help me if you have further solutions to my problem.
Regards

happy March 5, 2012 00:05

Got it
 
Quote:

Originally Posted by ghorrocks (Post 347617)
I thought that setting double precision at the commend line over-rode any setting from CFX-Pre but your comment suggests this is not so. In that case I would open it in CFX-Pre and toggle th double precision to on.

got it,, I do not need any further explaination, thanks Glenn so much:D

happy March 5, 2012 00:58

Quote:

Originally Posted by ghorrocks (Post 347617)
I thought that setting double precision at the commend line over-rode any setting from CFX-Pre but your comment suggests this is not so. In that case I would open it in CFX-Pre and toggle th double precision to on.

Yep,, it is working....
Thanks for your good input, Glenn:rolleyes:


All times are GMT -4. The time now is 19:40.