CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CFX (http://www.cfd-online.com/Forums/cfx/)
-   -   Error in FSI simulation (http://www.cfd-online.com/Forums/cfx/99357-error-fsi-simulation.html)

ashtonJ April 2, 2012 02:32

Error in FSI simulation
 
Dear all,

I am doing FSI simulation in a constricted model. The following error occurred in the middle of solution.

ERROR #002100061 has occurred in subroutine SERVE_CLIENTS. |
| Message: |
| The connection between this CFX process and an external process |
| has died unexpectedly. The following error was received: |
| External process : ANSYS |
| Error experienced : Read


Does anybody know where the error comes from.
Thank you.
Regards,'
AshtonJ

Lance April 2, 2012 10:36

If you'd bother to use the search function on the forum you wound find that it's because the solid solver died. See the output from mechanical to found out why.

ashtonJ April 2, 2012 19:36

Thank you very much. The following crash recovery file is written, however, I don't know how I can open the file to see where the problem is from. Do you know how this crash file can help me to diagnose the problem.

"Fluid_006.res.er"

The following error message is also given:

Fatal error occurred when requesting Total Mesh Displacement for Interface.

Is this problem because of mesh?

appreciate your help.
Regards,
AshtonJ

Lance April 3, 2012 02:05

Have a look at the ANSYS.stdout and ANSYS.err files

ashtonJ April 11, 2012 21:49

Quote:

Originally Posted by Lance (Post 352823)
Have a look at the ANSYS.stdout and ANSYS.err files

Dear Lance,

I've got the same error message for a very simple FSI problem. I tried to do FSI simulation in a straight pipe with sinusoidal pressure waveform at inlet and zero pressure at outlet. First, I used very small mesh numbers for fluid and solid parts (8500 elements), the solution converged, however, I did not observe any mesh displacement, it was like a solid body. Then, I increased the number of mesh elements to 45000, the following error message was given:

"The connection between this CFX process and en external process has died unexpectedly. The following error message was received.
External process: Ansys
Error experienced: Read"

As you recommended, I checked ANSYS.stdout and ANSYS.err files, could not find any helpful information, there was just a warning that the “maximum number of stagger iterations has been reached for multifield solver but the interface quantities have not yet converged. The analysis will proceeds to the next time step. Increase number of
stagger iterations using the MFITER command for converged interface solution.”


There is an ANSYS FSI tutorial which is quite similar to my problem, it's "2way transient FSI in a hose". Does anybody know how I can find it. I tried to get it from Ansys customer portal web, however, could not find it.

Thank you.
regards,
AshtonJ

lzw2003 April 12, 2012 10:28

Hi,
i got this problem:
+--------------------------------------------------------------------+
| ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| CFX encountered the error: Read. Fatal error occurred when reque- |
| sting Total Mesh Displacement for interface.

this may be the same to some of ashtonJ's problem. Some say this may be the problem of the mesh, i will try it tomorrow.

Do you solve this problem? Could you give me some information?


All times are GMT -4. The time now is 17:52.