CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   Edge (http://www.cfd-online.com/Forums/edge/)
-   -   Building Edge 5.0 [r2059] with new version of CGNS and LAPACK library. (http://www.cfd-online.com/Forums/edge/87938-building-edge-5-0-r2059-new-version-cgns-lapack-library.html)

Alth May 3, 2011 08:58

Building Edge 5.0 [r2059] with new version of CGNS and LAPACK library.
 
Hi,

I wonder how to compile Edge sources with new version of CGSN and LAPACK library.

I've tried with:
- CGNS 3.1 (Edge supports only ADF version of library, I set it (without HDF5, SZIP, ZLIB), but it dosent work);
- LAPACK 3.3.1 (Makefile recognize the library when I set the proper path, but with this version it cause crush during compilation);

Im using GCC 4.5 compiler on Linux64 architecture.

Thanks for any advice.
Alth

enp May 3, 2011 11:30

Hi,

we have recently modified the configure script to recognize CGNS 3.1. If you use the latest trunk version this should now work.
You can always modify the file config.mk by hand also with older versions. The the cgns conversion programs will be generated.

Sorry to say that I dont have an up to date Lapack installation available so I am not able to help you with this.

Kind regards,
Peter


All times are GMT -4. The time now is 08:01.