CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   Edge (http://www.cfd-online.com/Forums/edge/)
-   -   segamentation fault (http://www.cfd-online.com/Forums/edge/94128-segamentation-fault.html)

airsupply November 7, 2011 00:12

segamentation fault
 
For preprocessor command, it displays:

[air@localhost wb2]$ preprocessor wb.ainp
********** DUAL STARTS **********
Input file (.ainp) ?
wb.ainp

Reading file: "wb.ainp"
done.
Reading file: "wb.aboc"
done.
Reading file: "wb.bmsh"
done.
Title: Grid converted from CGNS
No. of dimensions: 3
No. of nodes: 4454406
No. of regions: 1
No. of boundaries: 5

Checking for duplicate nodes
/home/air/x86_64/bin/preprocessor: line 59: 7667 segamentation fault (core dumped) $DIR/dual${POSTFIX}.x <<EOD
'$1'
EOD

I usually type 'ulimit -s unlimited' before the preprocessor, and the error won't happen. Unfortunately, I am now dealing with a mesh with more then 15 million nodes, and even the 'ulimit -s unlimited' doesn't work either. I am confused, can sombody help me?

Best Regards
Alvin

sunti December 20, 2011 01:55

if you are using ubuntu/bash try the following command before you run the pre-processor and it should work

ulimit -s unlimited

if you are using another shell/distribution the command might be slightly different

but if you are using that many cells make sure that the computer has enough RAM

airsupply December 21, 2011 08:15

Quote:

Originally Posted by sunti (Post 336412)
if you are using ubuntu/bash try the following command before you run the pre-processor and it should work

ulimit -s unlimited

if you are using another shell/distribution the command might be slightly different

but if you are using that many cells make sure that the computer has enough RAM

Yes, the OS is Fedora 13 with a bash shell. I am pretty sure the RAM is enough--when the serial preprocessor goes to agglom.x routine the error occurs, but the RAM(16GB) consumed is less than 50% monitored by "top" command. I don't know if the segamentation fault is caused by the bug of preprocessor. Another possibility is that the error may comes from the grid which is generated by ICEM and outputed to CGNS-FLUENT formant, and then converted to FFA format.

filipwa December 29, 2011 03:28

Quote:

Originally Posted by airsupply (Post 336611)
Yes, the OS is Fedora 13 with a bash shell. I am pretty sure the RAM is enough--when the serial preprocessor goes to agglom.x routine the error occurs, but the RAM(16GB) consumed is less than 50% monitored by "top" command. I don't know if the segamentation fault is caused by the bug of preprocessor. Another possibility is that the error may comes from the grid which is generated by ICEM and outputed to CGNS-FLUENT formant, and then converted to FFA format.

How did you manage to export the grid in CGNS format from ICEM? I have tried all possible combinations of exporting from ICEM and then converting to FFA without any success...

The only way that works for me is if I export it to Fluent's format first and then in Fluent export it as CGNS...

airsupply January 12, 2012 03:10

Quote:

Originally Posted by filipwa (Post 337239)
How did you manage to export the grid in CGNS format from ICEM? I have tried all possible combinations of exporting from ICEM and then converting to FFA without any success...

The only way that works for me is if I export it to Fluent's format first and then in Fluent export it as CGNS...

Yes, I used to do exactly the same as yours.

basneb January 14, 2012 08:42

Quote:

Originally Posted by filipwa (Post 337239)
How did you manage to export the grid in CGNS format from ICEM? I have tried all possible combinations of exporting from ICEM and then converting to FFA without any success...

The only way that works for me is if I export it to Fluent's format first and then in Fluent export it as CGNS...

For me it works directly like this:

>> cgns2ffa -g [grid.cgns] [grid.bmsh]

I don't know, but maybe it depends on the settings you have when exporting from ICEM to cgns.

filipwa January 15, 2012 10:16

Quote:

Originally Posted by basneb (Post 339300)
For me it works directly like this:

>> cgns2ffa -g [grid.cgns] [grid.bmsh]

I don't know, but maybe it depends on the settings you have when exporting from ICEM to cgns.

Which version of ICEM are you using? Can you tell me what settings and cgns version you are exporting to? I have tried all combinations i can think of without any success at all...

basneb January 17, 2012 05:32

Quote:

Originally Posted by filipwa (Post 339399)
Which version of ICEM are you using? Can you tell me what settings and cgns version you are exporting to? I have tried all combinations i can think of without any success at all...

Well, it has been a while, since I did that, but here is what I remember:

- Input grid: unstruct
- Create default BC patches: no
- entities for BC: face elements
- create bar/node elements: yes
- cgns version: 2.2

if this is not working for you, what would be the error message you receive from edge?

btw: my ICEM version is 13.0

jka February 24, 2012 14:09

I use (off the top of my head, do not have Icem on my screen)

- Input grid: unstruct
- Create default BC patches: yes
- entities for BC: face elements
- create bar/node elements: no
- cgns version: 2.4
I use ICEM version is 13.0

Let me know if it worked, if not I can make a snapshot of the Icem export screen and upload it


All times are GMT -4. The time now is 00:27.