CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   enGrid (http://www.cfd-online.com/Forums/engrid/)
-   -   engrid 1.4 installation problem in openSUSE 12.3 and 13.1 (http://www.cfd-online.com/Forums/engrid/130530-engrid-1-4-installation-problem-opensuse-12-3-13-1-a.html)

taxalian February 27, 2014 14:58

engrid 1.4 installation problem in openSUSE 12.3 and 13.1
 
Hi,
I am using Opensuse 12.3 and i want to install engrid 1.4 stable release. But the installation also complains about the vtk version is newer than the one required. It always recommends to deinstall the current new version and use the old one.
But i am using the current latest vtk version together with the OpenFOAM+Paraview installation. Please help me in resolving this issues. I tried to install engrid via git install using the "build.bash" file with both the generic linux and opensuse 12.3 argument.

Thanks.

wyldckat March 1, 2014 08:43

Greetings taxalian,

I need more information, in order to reproduce the same problem, namely:
  1. What is the exact error message you're getting?
  2. Which VTK version are you trying to use?
  3. What OpenFOAM+ParaView versions are you using and how did you install them?

But my guess is that the problem is that you might be trying to use VTK 6.0, which is the default version as of ParaView 3.98. Unfortunately, that version of VTK is incompatible with enGrid 1.4. The last known compatible version is VTK 5.10.

Best regards,
Bruno

taxalian March 1, 2014 17:05

Hi Bruno,
Thanks for the reply, Here is the reply for your questions:

1. What is the exact error message you're getting?

Well the error message is about the VTK version conflict, i am using 6.0
and the engrid installation recommends to deinstall the v6.0 and use the
old one. But is it ok to use the old VTK version 5.10.

2.Which VTK version are you trying to use?

I would like to stick with the currently running version 6.0

3. What OpenFOAM+ParaView versions are you using and how did you install them?

Well i am using OpenFOAM 2.2.0 & ParaView 3.12. I installed the compiled binary versions.

Thanks and regards.

wyldckat March 4, 2014 09:50

Hi taxalian,

I had a look into openSUSE 13.1 the other day and it didn't even provide VTK 5.10 :( I suspect that openSUSE 12.3 is in the same situation.

AFAIK, only the latest enGrid development version (1.5, I think) might be able to operate with VTK 6.0, but I haven't confirmed it yet.

If you had built ParaView 3.12.0 from source code, you could use the VTK build from ParaView 3.12.0.

Beyond this, I suggest that you contact enGits official support line: http://engits.eu/en/support - they should be able to tell you whether it's safe to use the latest enGrid version that is in the master branch or if they can provide a port of enGrid 1.4 for VTK 6.0.

Best regards,
Bruno

ogloth March 4, 2014 13:36

Hi,

I can confirm that the master branch works with VTK6 -- openSUSE 13.1 being the reason for the switch ;-)

Having said that, the master branch has a few issues on certain geometries. Most of the time, however, it works reasonably well. It is still a fair bit away from a new release, but we have planned to devote some time to enGrid in the coming weeks (as far as other commercial projects permit).

Best regards,
Oliver


All times are GMT -4. The time now is 14:11.