CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FloEFD, FloWorks & FloTHERM

Mutiple Model Batch Runs

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 20, 2008, 02:49
Default Mutiple Model Batch Runs
  #1
Nick Sessions
Guest
 
Posts: n/a
Hello

I seem to be running into problems when I run batch runs of a number of configurations (projects) for multiple models and want to know if anyone else is having the same trouble.

To clarify: I have a model A which has configurations A1, A2, A3... also model B and B1, B2, B3... and C with C1, C2, C3... ...

I have all the models (A, B, C...) open in EFD.Lab. Then I run a batch. SolidWorks/EFD.Lab has closed down by the time I check after the weekend.

The models are smallish and I have 8GB memory. Even if the memory is exhausted I don't expect there to be no trace of SW/EFD when I return.

On another note: is anyone surprised that SW has to close down/crash when there is "not enough memory" to, say, mesh some geometry?

Cheers Nick

  Reply With Quote

Old   September 4, 2008, 09:01
Default Re: Mutiple Model Batch Runs
  #2
Murat
Guest
 
Posts: n/a
First I do not know anythging about your license. May be your license does not have batch run module so it happened.

If you do not have batch run module you can use batch run but only a model. For passing thourgh the second model, EFD closed down.

Second scenerio

If you set up result resolution level 6. Up to Level 5 include dynamic mesh(not moving) means refinement mesh. Always EFD find out good resutl to change the meshes. I think you decrease mesh resolution if the level is higher than level5 and try again.

Also, you can set up manual refinement mesh, narrow channel, small solid meshes. You should set up again. I think you can set up default.

  Reply With Quote

Old   September 5, 2008, 08:06
Default Re: Mutiple Model Batch Runs
  #3
Nick Sessions
Guest
 
Posts: n/a
Dear Murat

(1) EFD.Lab allows batch runs across multiple open files. Do you use another product (Floworks; Flotherm; Flovent [I am only intimately familiar with EFD.Lab]) that requires another license or module to run batch runs?

(2) Please elaborate this idea, it sounds interesting.

What I would like to know from you (or anyone else with experience) is: when you run multiple model batch runs whether your computer crashes.

Many thanks Nick

  Reply With Quote

Old   September 5, 2008, 14:05
Default Re: Mutiple Model Batch Runs
  #4
Dan E.
Guest
 
Posts: n/a
Nick,

I have had similar situations with batch runs on multiple models with multiple configurations. I found out that there can not be any components of the assemblies with the same name. For example, if model A.SLDASM with all of its configurations uses a component called EndCap.sldprt, and model B.SLDASM also uses a component called EndCap.sldprt, then the program would shut down. The solution was to change the names of the subcomponents. Model A.SLDASM should only use name such as Part1A.sldprt, Part2A.sldprt, Part3A.sldprt, …, and model B.SLDASM should use components named Part1B.sldprt, Part2B.sldprt, Part3B.sldprt,…. Obviously use any designation you wish, but they need to be different for each model.

I discovered this problem using a previous version of EFD.Lab (probably V6), and have not attempted to test it with the newest version (V8.2). I just make sure to name everything appropriately and as is well.

As for your issue about "not enough memory", I also have had this problem. The only fix at the time was to reboot the computer. Then directly launch EFD.Lab, and start the analysis with out doing anything else with the computer. Again, this was with a previous version. Since upgrading to V8.2, I have not seen this problem.

Hope this helps.

Dan

  Reply With Quote

Old   September 5, 2008, 14:11
Default Re: Mutiple Model Batch Runs
  #5
Nick Sessions
Guest
 
Posts: n/a
Brilliant! thanks, I'll look out for that. I also know not to use "%" in the configuration name as that also leads to trouble. /n

  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Superlinear speedup in OpenFOAM 13 msrinath80 OpenFOAM Running, Solving & CFD 18 March 3, 2015 06:36
multiphaseInterFoam for RAS turbulence model chiven OpenFOAM Bugs 7 August 23, 2011 02:52
Reynolds Stress model in CFX vs Fluent Tim CFX 1 October 7, 2009 06:19
multi fluid mixture model issue rystokes CFX 3 August 9, 2009 19:13
Model runs in icoFoam amp turbFoam but never in MRFSimpleFoam peter_watson OpenFOAM Running, Solving & CFD 0 April 1, 2008 09:02


All times are GMT -4. The time now is 05:28.