CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLOW-3D (http://www.cfd-online.com/Forums/flow-3d/)
-   -   Simulation VIDEO issue in v9.3 (http://www.cfd-online.com/Forums/flow-3d/27236-simulation-video-issue-v9-3-a.html)

Nikolaos October 2, 2008 03:28

Simulation VIDEO issue in v9.3
 
I recently upgraded to version 9.3 and I have the following problem:

When I am creating the video of the simulation, I can watch it being created frame by frame, but when I play the .avi file, the simulation starts from an intermediate frame. So, in .avi file I lose the whole process before this frame.

Have you noticed it, is there a setting that I have to do, or it is a bug?

Byongjun Park October 2, 2008 04:31

How about using "img2avi"?
 
Hi, Nikolaos.

I didn't upgrade to version 9.3 yet. But I will do it soon. (I'm using version 9.2.)

At once, delete these files.

C:\FLOW3D\gui\pref.f3d C:\FLOW3D\gui\flowvurespref.ini C:\FLOW3D\gui\flowvupref.ini

If possible, when you make the animation of simulation results, finish the solving and close any other windows(process). Because it required much memory.

If you want make the animation of simulation results as you, how about using "img2avi"? It's a freeware.

http://workshop.visiongs.de/img2avi/img2avi.zip

When you make the animation in FLOW-3D, off the option "delete source bitmap files", and don't make AVI file. Then you can find flame shots of the simulation results as BMP files.

Gook luck!

ck October 2, 2008 07:18

Re: How about using "img2avi"?
 
Nikolaos, I believe this is bug with v9.3 as i also experienced the same problem.

Regards CK

Nikolaos October 2, 2008 08:47

Re: How about using "img2avi"?
 
Byongjun Park,

Thank you very much for the hint, I downloaded the software, I will try asap and give my feedback here.

CK,

I think we are right about the bug, because when I move the flsgrf file to another computer with v9.2 it works fine. So, I am going to post this at the Flow3D official site.

Thanks!

Michael Barkhudarov October 2, 2008 09:10

Re: How about using "img2avi"?
 
Yes, this is a known problem in the 9.3 release and will be resolved in the upcoming patch. For now, the workaround is to create the bmp images and save them to the disk (from 2d or 3d plots), then open a DOS window and in the directory where the bmp files are run bmp2avi, which is located in the Utilities folder of the 9.2 installation:

> bmp2avi -c msvc -f 15

This will use the MS Video 1 compression and 15 frames per second, which can obviously be changed. Type

> bmp2avi -help

to see all available options.

Michael


All times are GMT -4. The time now is 04:04.