CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLOW-3D (http://www.cfd-online.com/Forums/flow-3d/)
-   -   Inkjet Simulation using Elastic Membrane Modeling (http://www.cfd-online.com/Forums/flow-3d/27327-inkjet-simulation-using-elastic-membrane-modeling.html)

Raju Han January 11, 2009 23:44

Inkjet Simulation using Elastic Membrane Modeling
 
Hello,

I was trying to simulate a piezoelectric inkjet ejection using the elastic membrane modeling (Flow3D V9.3). I have followed closely to the Microfluidics Tutorial to create the required prepin file as follow.

************************************************ &xput

remark='units are SI',

twfin=50e-6,

itb=1,

gz=9.8, imemb=1, imobs=1, ifsft=1,

ifvisc=1,

delt=1e-9, dtmax=1e-7, dtmin=1e-50, imp=2,

ihelp=2, lpr=3, hpltdt=0.0, pltdt=1e-6, /

&limits /

&props

rhof=1000.,

sigma=32e-3,

units='si',

mu1=15e-3, /

&scalar /

&bcdata

wl=2, wr=2, wf=2, wbk=2,

wt=3, /

&mesh

nxcelt=150, px(1)=-150e-6, px(2)=150e-6,

nycelt=150, py(1)=-150e-6, py(2)=150e-6,

nzcelt=50, pz(1)=0.0, pz(2)=100e-6, /

&obs

avrck=-3.1,

nobs=2, tobs(2)=2e-1, tobs(3)=2.1e-1, iob(1)=1,

xl(1)=-150e-6, xh(1)=150e-6, yl(1)=-150e-6,

yh(1)=150e-6, zl(1)=0., zh(1)=5e-06,

imb(1)=2, imbe(1)=1,

imbn(1)=3, xmbw(1)=100e-6, ymbw(1)=16e-6,

zmbw(1)=2e-6, xfmbw(1)=80e-6, yfmbw(1)=13e-6,

rpmbw(1)=0.4, embw(1)=190e9, rhombw(1)=7850.,

fmbw(1,1)=3e5, fmbw(2,1)=3e-5,

xcmbw(1)=0., ycmbw(1)=0.,

iob(2)=2, iob(3)=2, ioh(3)=0,

xl(2)=-150e-6, xh(2)=150e-6,

yl(2)=-150e-6, yh(2)=150e-6,

zl(2)=0., zh(2)=30e-6, zh(3)=3e-05, trnz(2)=60e-6,

zl(3)=0., rah(3)=15e-06, trnz(3)=6e-05,

iob(4)=2, ioh(4)=0, zl(4)=0., zh(4)=40e-6,

coneh(4)=35., rotx(4)=180.0, trnz(4)=95e-6,

imbe(2)=1, imbn(2)=3,

rambw(1)=140e-6, rfmbw(1)=135e-6,

famp(1)=1e-3, freq(1)=100., /

&fl

flht=90e-6, /

&bf /

&temp /

&motn /

&grafic /

&HEADER

PROJECT='InkJet_Rev1', /

************************************************** ***

I have been encountering the following errors:

* Pressure iteration diverging * Result in excessive pressure convergence failures.

I have tried the followings: 1. Enable the implicit automatic limited compressibility mode. 2. Using GMRES 3. Reduce the step time to 1e-25 4. Increase the maximum number of iterations. 5. Reduce to the applied force to very small.

I am clueless why the simulation is not working.

Any suggestion!!!!

Best regards, Raju


michael barkhudarov January 14, 2009 11:35

Re: Inkjet Simulation using Elastic Membrane Model
 
Hi Raju,

Try turning off automatic limited compressibility and the mentor, i.e., set IMP=1 and IHELP=1.

Are you using implicit coupling between the membrane and fluid? I think this may be the default.

Also, you may look at the "micro-pump" example provided with the installation, which uses the membrane model, for clues.

If all does not work I suggest contacting support for a closer look.

Michael


All times are GMT -4. The time now is 18:20.