CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Fluent UDF and Scheme Programming (
-   -   UDF - Error loading libudf (

QuocHung_Phan October 30, 2012 20:45

UDF - Error loading libudf
Hi, i use fluent 14, cfree4_1_pro and win7 x64
i've succesfully compiled my udf, but when i load it fluent says:
The UDF library you are trying to load (libudf) is not compiled for 2ddp on the curent platform (win64).
what should i do?
Thank you.

davidwilcox October 31, 2012 00:09

I copied this from the cfd online fluent wiki. This might solve your problem:
How can I manage to compile my UDF with Windows 7 64bit?

This problem sometimes looks similar to the one concerning the missing 'nmake'.
  • Install Visual Studio. Most of the time the Visual C++ 2008 Express Edition [3] is recommended. On my system it even works with the new Visual Studio 2010 Professional Release Candidate [4].
  • Set the correct environment variables. Browse your way through the Windows system control to 'System'. There you will find a section 'Advanced system settings'. In the following dialog go to the 'Advanced' tabulator and click on 'Environment variables' (lower right corner). Go through the 'System variables' list and search for the 'Path' entry. Add the following to the variable: C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\Tools;C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin;C:\Program Files\ANSYS Inc\v120\fluent\ntbin\win64. Adjust this entry to your system concerning the installation directories! The Visual Studio entry should point to the location where 'nmake' is located.
  • Install a Software Development Kit (SKD) for 64bit systems. This may be the difference between 32bit and 64bit systems. I have used the .NET Framework 2.0 Software Development Kit (SDK) (x64) from 2006 [5] because it is explicitly for 64bit systems and I was not sure if more recent versions are for 64bit systems as well.
  • Start FLUENT from the SDK command prompt. Do not use the Visual Studio command prompt, use the SDK command prompt! Go to the directory your case is in and type 'fluent'.
Hope this helps. :)

QuocHung_Phan November 1, 2012 21:15

thanks for your help.

All times are GMT -4. The time now is 05:06.