CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Fluent UDF and Scheme Programming

Error: open_udf_library:

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 26, 2012, 05:30
Default
  #21
New Member
 
Peter
Join Date: Jan 2012
Posts: 29
Rep Power: 4
peatmac is on a distinguished road
Hey Guys,

I am facing similar problems to many people on this thread. I have followed Ivan's steps. My knowledge in using the Command Prompt is very limited.

Can anyone point me in the right directions on how to navigate on the MS-DOS windows to the working directory?

Many thanks in advance

Peter
peatmac is offline   Reply With Quote

Old   January 26, 2012, 05:35
Default
  #22
Member
 
EH
Join Date: Dec 2010
Posts: 60
Rep Power: 5
ehooi is on a distinguished road
Quote:
Originally Posted by peatmac View Post
Hey Guys,

I am facing similar problems to many people on this thread. I have followed Ivan's steps. My knowledge in using the Command Prompt is very limited.

Can anyone point me in the right directions on how to navigate on the MS-DOS windows to the working directory?

Many thanks in advance

Peter
Try checking this thread.

someone help me please with my UDF
ehooi is offline   Reply With Quote

Old   January 27, 2012, 08:24
Default
  #23
New Member
 
Peter
Join Date: Jan 2012
Posts: 29
Rep Power: 4
peatmac is on a distinguished road
Afternoon,

That thread has helped me greatly. Am I right in understanding that Microsoft Visual 2008 C++ is a 32-bit compiler, and will not compile 64-bit functions? I am running Fluent 6.3.26 64-bit on Windows 7. Will this be an issue for me?

Currently I am using compiled functions (in tutorials I have downloaded). I can build them but not load them. The error that I get is that Fluent can not find the libudf file. I have tried changing the library name in the working folder, but still I am not having any success.

Thanks again for all your help.

Peter
peatmac is offline   Reply With Quote

Old   January 27, 2012, 08:28
Default
  #24
Member
 
EH
Join Date: Dec 2010
Posts: 60
Rep Power: 5
ehooi is on a distinguished road
I am not sure about that, but for some reason, it didnt work. It is only wiht 2010 that I got the UDFs to run.

Quote:
Originally Posted by peatmac View Post
Afternoon,

That thread has helped me greatly. Am I right in understanding that Microsoft Visual 2008 C++ is a 32-bit compiler, and will not compile 64-bit functions? I am running Fluent 6.3.26 64-bit on Windows 7. Will this be an issue for me?

Currently I am using compiled functions (in tutorials I have downloaded). I can build them but not load them. The error that I get is that Fluent can not find the libudf file. I have tried changing the library name in the working folder, but still I am not having any success.

Thanks again for all your help.

Peter
ehooi is offline   Reply With Quote

Old   January 27, 2012, 08:38
Default
  #25
New Member
 
Peter
Join Date: Jan 2012
Posts: 29
Rep Power: 4
peatmac is on a distinguished road
I will get Visual 2010. Re run the problem and let you all know.

Cheers
peatmac is offline   Reply With Quote

Old   February 7, 2012, 16:05
Default
  #26
New Member
 
Peter
Join Date: Jan 2012
Posts: 29
Rep Power: 4
peatmac is on a distinguished road
Really simple answer to this, my lack of experience did not help me. You must launch Fluent through your command promt. Simply type in fluent in you command promt and continue as normal. Thanks for the help guys!
peatmac is offline   Reply With Quote

Old   February 8, 2012, 02:30
Default
  #27
Member
 
kabilan.B
Join Date: Jul 2010
Location: chennai
Posts: 69
Rep Power: 6
kabilan is on a distinguished road
hi mr.
i have problem with my udf for my dynamic mesh problem. i have udf file while use this the same open problem shows. i m using win7 64bit... could u pls help me to install visual studio and how can i work......
kabilan is offline   Reply With Quote

Old   February 8, 2012, 04:45
Default
  #28
New Member
 
Peter
Join Date: Jan 2012
Posts: 29
Rep Power: 4
peatmac is on a distinguished road
http://www.microsoft.com/visualstudi...itions/express

Download Visual from the link above. Also ensure your C Source file is in the same folder level as your mesh/cas and libudf folder, in your working folder.
peatmac is offline   Reply With Quote

Old   February 13, 2012, 10:18
Default udf
  #29
Member
 
kabilan.B
Join Date: Jul 2010
Location: chennai
Posts: 69
Rep Power: 6
kabilan is on a distinguished road
hi mr
cant get u.can you please elaborate it?
thank you
kabilan is offline   Reply With Quote

Old   February 13, 2012, 10:23
Default
  #30
Member
 
EH
Join Date: Dec 2010
Posts: 60
Rep Power: 5
ehooi is on a distinguished road
Quote:
Originally Posted by kabilan View Post
hi mr
cant get u.can you please elaborate it?
thank you
Check this thread to get more information
someone help me please with my UDF
ehooi is offline   Reply With Quote

Old   June 6, 2012, 15:30
Default
  #31
Senior Member
 
ghost82's Avatar
 
Daniele
Join Date: Oct 2010
Location: Italy
Posts: 542
Rep Power: 11
ghost82 will become famous soon enough
wrong post, sorry
ghost82 is offline   Reply With Quote

Old   June 12, 2012, 06:20
Default
  #32
New Member
 
Join Date: Aug 2009
Posts: 6
Rep Power: 7
amindavari is on a distinguished road
hi guys
I'm facing a problem concerning compile udf. i did all things that were mentioned above. but i still have the problem entitled" system can not find spicifed file". log file is created and has this error (((NMAKE : U1073: don't know how to make '..\..\src\heat'
Stop.)))

this is my udf:
-----------------------------------
#include"udf.h"
DEFINE_PROFILE(heatflux, thread, position)
{
real y[ND_ND];

real z;
face_t f;
begin_f_loop(f, thread)
{
F_CENTROID(y,f,thread);
z = y[2];
F_PROFILE(f, thread, position) = 283889.07*cos((4.0*atan(1.0)/0.815)*(z+0.01005));
}
end_f_loop(f, thread)
}
---------------------------------------------------
could anyone help me

thank you in advance
amindavari is offline   Reply With Quote

Old   May 30, 2013, 08:54
Default
  #33
New Member
 
Join Date: May 2013
Posts: 2
Rep Power: 0
snehapag is on a distinguished road
Quote:
Originally Posted by IvanCFD View Post
Hello Karthick,

I'm having a nightmare with trying to compile a UDF.

I'm a beginner about dealing with UDFs on Windows-based Fluent 2D.

When I load the UDF, I get the following message:

- "nmake" not recognized as an internal or external command, operable program or batch file.

I've seen out there that it is an issue related to the interaction between Fluent and Visual Studio To solve it, during the installation process, one needs to select the "register environment variables" option. However, I haven't seen such option during Fluent installation. This is what I've done step by step:

1) Install full Microsoft Visual Studio 2008.

2) Install Windows-based Fluent.

3) Go to "Start" --> "All Programs" --> "Fluent Inc Products" --> "Fluent 6.3.26" --> "Set Environment"

After doing all that, I still couldn't load my UDF. Same error message.

Then I downloaded nmake.exe and installed at \Fluent.Inc\fluent6.3.26\ntx86 and also at WINDOWS\system32, I opened a command prompt and executed nmake. After doing all this, back on Fluent I was able to get rid of the nmake error message.

However I now get another error message:

Opening library "libudf"...
Error: open_udf_library: (...)


I installed Visual Studio 2008 and I didn't say at any step to whether path to be set or not. But after doing the "Set Enviroment" thing I checked that PATH is at ntx86.

Would you please let me know what I'm missing?

Many thanks beforehand,

Ivan.
i am facing the same problem..and getting nightmares too...nmake error is corrected. the next error simply implies that the object file is not created at all. that means the c code is not complied.
can anyoone please help???

using windows 7 64 bit and visual studio 2010
snehapag is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 18:23.