CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Fluent UDF and Scheme Programming

Error: open_udf_library:

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 9, 2004, 17:24
Default Error: open_udf_library:
  #1
dhananjay
Guest
 
Posts: n/a
Hello,

i am facing a problem in using compiled UDF. interpreted UDF is working fine, but when i use same code with compiled UDf it gives me following error message.

Opening library "libudf"... Error: open_udf_library: The system cannot find the file specified.

the log file in 'libudf/ntx86/2ddp' shows following:

'cl' is not recognized as an internal or external command, operable program or batch file. NMAKE : U1077: 'cl' : return code '0x1' Stop.

any help in this regard will be appreciated.

with kind regards, dhananjay.

  Reply With Quote

Old   July 12, 2004, 07:11
Default Re: Error: open_udf_library:
  #2
Karthick
Guest
 
Posts: n/a
Hello Dhananjay

please check whether Visual Studio is installed correctly in your system. Because this error will come when u have not specified the path for visual studio. Try to interpret the udf. If it works good, then it is the problem with visual studio only.

Regards Karthick

  Reply With Quote

Old   July 12, 2004, 07:53
Default Re: Error: open_udf_library:
  #3
Javier
Guest
 
Posts: n/a
Hello:

I have the same problem. how can i fix the route in fluent to the visual studio? What should i put in the header file section?

Thanks
  Reply With Quote

Old   July 12, 2004, 08:19
Default Re: Error: open_udf_library:
  #4
Karthick
Guest
 
Posts: n/a
Dear Javier,

You please reinstall visual studio again. while installing it'll ask to whether path to be set or not?

Otherwise you specify the your email address. I'll send u the html file showing how to specify the path to fluent. Otherwise check the old posts.

Regards Karthick
  Reply With Quote

Old   July 12, 2004, 10:10
Default Re: Error: open_udf_library:
  #5
dhananjay
Guest
 
Posts: n/a
Hello Karthick,

thanks a lot for your kind reply. the problem was in Visual Studio. interpreted UDF worked perfectly. i think that now i can fix the problem.

thanks again for your advice,

with kind regards, dhananjay.

  Reply With Quote

Old   February 13, 2010, 18:52
Default
  #6
Member
 
Ivan
Join Date: Aug 2009
Posts: 63
Rep Power: 7
IvanCFD is on a distinguished road
Hello Karthick,

I'm having a nightmare with trying to compile a UDF.

I'm a beginner about dealing with UDFs on Windows-based Fluent 2D.

When I load the UDF, I get the following message:

- "nmake" not recognized as an internal or external command, operable program or batch file.

I've seen out there that it is an issue related to the interaction between Fluent and Visual Studio To solve it, during the installation process, one needs to select the "register environment variables" option. However, I haven't seen such option during Fluent installation. This is what I've done step by step:

1) Install full Microsoft Visual Studio 2008.

2) Install Windows-based Fluent.

3) Go to "Start" --> "All Programs" --> "Fluent Inc Products" --> "Fluent 6.3.26" --> "Set Environment"

After doing all that, I still couldn't load my UDF. Same error message.

Then I downloaded nmake.exe and installed at \Fluent.Inc\fluent6.3.26\ntx86 and also at WINDOWS\system32, I opened a command prompt and executed nmake. After doing all this, back on Fluent I was able to get rid of the nmake error message.

However I now get another error message:

Opening library "libudf"...
Error: open_udf_library: (...)


I installed Visual Studio 2008 and I didn't say at any step to whether path to be set or not. But after doing the "Set Enviroment" thing I checked that PATH is at ntx86.

Would you please let me know what I'm missing?

Many thanks beforehand,

Ivan.
IvanCFD is offline   Reply With Quote

Old   February 27, 2010, 09:22
Smile error:open~~~
  #7
New Member
 
sunqiang
Join Date: Nov 2009
Posts: 23
Rep Power: 7
matthewsun is on a distinguished road
hi,mate!
i am facing the same problem and still can't figure it out.
i set the envionmental variables of Administrator as follows:

include:E:\programe files\microsoft visual studio 9.0 \vc\include
lib:E:\programe files\microsoft visual studio 9.0 \vc\lib
path:E:\programe files\microsoft visual studio 9.0 \common7\IDE

i followed the remedy online,but i guess they must've missed something.
matthew
looking fwd to ur reply
matthewsun is offline   Reply With Quote

Old   February 28, 2010, 00:00
Default
  #8
New Member
 
sunqiang
Join Date: Nov 2009
Posts: 23
Rep Power: 7
matthewsun is on a distinguished road
hi,Ivan
oops,this problem has been bothering for the past couple of days,but after working on it a whole day yesterday,i managed to figure it out, it's the settings of environmental variables that matter.
matthewsun is offline   Reply With Quote

Old   February 28, 2010, 06:38
Default
  #9
Member
 
Ivan
Join Date: Aug 2009
Posts: 63
Rep Power: 7
IvanCFD is on a distinguished road
Hi matthewsun,

sorry for the late reply.

Yes, that's rhe whole thing.

What worked to me was the following (and just with Visual Studio Express):

1) Start -> Fluent Inc. -> Set Environment variables

2) Start -> Visual Studio -> Prompt symbol .... MS-DOS windows appears

The fact of opening that MS-DOS windows through Visual Studio makes, somehow, prepare the communication between C++ and Fluent.

3) Navigate on that MS-DOS windows up to your working directory and type fluent <model>.

That's all.

Cheers,

Ivan.

Quote:
Originally Posted by matthewsun View Post
hi,Ivan
oops,this problem has been bothering for the past couple of days,but after working on it a whole day yesterday,i managed to figure it out, it's the settings of environmental variables that matter.
IvanCFD is offline   Reply With Quote

Old   March 3, 2010, 04:13
Default
  #10
New Member
 
sunqiang
Join Date: Nov 2009
Posts: 23
Rep Power: 7
matthewsun is on a distinguished road
hi,Ivan
sorry for the late reply.
i have to say this udf compiling thing is really pretty boring,the message 'error ~~~' ocurrs again,i unintalled the visual studio and reinstalled,and did the settings as those on the network ,but it failed to work,so i am really sorry,i'll send you the remedy once i work it out.
matthew
matthewsun is offline   Reply With Quote

Old   May 8, 2010, 04:53
Default
  #11
Member
 
Ivan
Join Date: Aug 2009
Posts: 63
Rep Power: 7
IvanCFD is on a distinguished road
Hi Matthew,

sorry for the late reply.

If you follow my post "February 28, 2010, 09:38" it should work. I did just that, and it just worked.

I recommend you to do exactly what I bulleted, unistall any Visual Studio you've got and install Visual Studio Express from scratch. That's what I did and, as said, no more errors appeared.

Cheers,

Ivan.
IvanCFD is offline   Reply With Quote

Old   May 9, 2010, 22:21
Default
  #12
New Member
 
sunqiang
Join Date: Nov 2009
Posts: 23
Rep Power: 7
matthewsun is on a distinguished road
Hi Ivan,
I uninstalled the visual studio 2008 and installed the VC6,i didn't do any changes to the environmental variables ,it worked!
Thanks anyway
matt
matthewsun is offline   Reply With Quote

Old   May 13, 2010, 14:25
Default
  #13
Member
 
Ivan
Join Date: Aug 2009
Posts: 63
Rep Power: 7
IvanCFD is on a distinguished road
Hi Matt,

I had refreshed my computer and now I want to run a UDF I just can't.

I followed all the steps I bulleted above and it just doesn't want to work.

You say you unistalled Visual Studio 2008 and installed VC6. What's VC6?

Yo say you don't have to set the environment variables. So, how do you launch Fluent? Do you have to go through by the Command Prompt?

Cheers,

Ivan.
IvanCFD is offline   Reply With Quote

Old   May 13, 2010, 14:48
Default
  #14
Member
 
Ivan
Join Date: Aug 2009
Posts: 63
Rep Power: 7
IvanCFD is on a distinguished road
Hey again Matt,

no worries, "my" approach still works!

The problem was in the way my .c file was coded, with some coding mistakes.

Now everything works as I expected.

Thanks anyway,

Ivan.
IvanCFD is offline   Reply With Quote

Old   July 3, 2010, 16:32
Default problem compiling UDF
  #15
New Member
 
banerji
Join Date: Dec 2009
Posts: 22
Rep Power: 7
banerji is on a distinguished road
Hi Matthiew and Ivan,

I looked at your posts and it seems I am having a problem you had long time ago but I followed your methods of setting environments without success. we recently switched to Fluent 12.1.4 and I have hard time compiling my UDF. Does any body of you use this Fluent version?
banerji is offline   Reply With Quote

Old   July 4, 2010, 02:43
Default
  #16
New Member
 
sunqiang
Join Date: Nov 2009
Posts: 23
Rep Power: 7
matthewsun is on a distinguished road
well,this is not longer a problem for us, like i said ,i uninstall the visual studio 2008 and installed vc++,i remember a dialog box would come up at the end of installation about setting environment variables and i clicked yes ,then i could compile the codes,if this still bothers you,i'll see if i can make a video or something
matthew
matthewsun is offline   Reply With Quote

Old   July 4, 2010, 16:04
Default
  #17
Member
 
Ivan
Join Date: Aug 2009
Posts: 63
Rep Power: 7
IvanCFD is on a distinguished road
Hi Banerji,

I installed Visual Studio Express (the free version) and did the following:

1) Start -> Fluent Inc. -> Set Environment variables

2) Start -> Visual Studio -> Prompt symbol .... MS-DOS windows appears

The fact of opening that MS-DOS windows through Visual Studio makes, somehow, prepare the communication between C++ and Fluent.

3) Navigate on that MS-DOS windows up to your working directory and type fluent <model>.

This works for me.

With respect to Fluent 12, sorry but I haven't work with it in depth yet.

Cheers,

Ivan.
IvanCFD is offline   Reply With Quote

Old   July 4, 2010, 20:01
Default
  #18
New Member
 
banerji
Join Date: Dec 2009
Posts: 22
Rep Power: 7
banerji is on a distinguished road
Thanks guys for replying. hey Matthiew which Fluent Version are you using?
banerji is offline   Reply With Quote

Old   August 14, 2010, 15:37
Default
  #19
New Member
 
Alvin Simer
Join Date: Aug 2010
Posts: 2
Rep Power: 0
als_226 is on a distinguished road
Hi guys, i followed the steps above but instead i got this problem,

"Error: open_udf_library: %1 is not a valid Win32 application.

Error Object: ()"

I can't find any solutions to this matter. I hope you guys can help me regarding this problem.
als_226 is offline   Reply With Quote

Old   January 14, 2011, 11:27
Default
  #20
Member
 
EH
Join Date: Dec 2010
Posts: 61
Rep Power: 6
ehooi is on a distinguished road
Quote:
Originally Posted by IvanCFD View Post
Hi matthewsun,

sorry for the late reply.

Yes, that's rhe whole thing.

What worked to me was the following (and just with Visual Studio Express):

1) Start -> Fluent Inc. -> Set Environment variables

2) Start -> Visual Studio -> Prompt symbol .... MS-DOS windows appears

The fact of opening that MS-DOS windows through Visual Studio makes, somehow, prepare the communication between C++ and Fluent.

3) Navigate on that MS-DOS windows up to your working directory and type fluent <model>.

That's all.

Cheers,

Ivan.
Hi,
Do you think this will work using Microsoft Visual Studio 9.0? Also I am using Ansys Fluent 12.1, which means there isnt the Set Environment option from the Start Menu.

Thanks.

EH
ehooi is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:08.