CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   Fluent UDF and Scheme Programming (http://www.cfd-online.com/Forums/fluent-udf/)
-   -   Error compile file udf (http://www.cfd-online.com/Forums/fluent-udf/65511-error-compile-file-udf.html)

czfluent June 17, 2009 05:34

Error compile file udf
 
Hi everybody :D

I have problem with compile udf in Windows XP x64bit.
I compiled and used a UDF succesfully on Linux, but it fails to compile on Windows. So Im using Fluent version Fluent-ntx86-6.3.26.
This is my file whose I need compile:

Code:

http://rapidshare.com/files/245477895/manualUDFexmaple_2.3.27__ex1_.c.html

And here is error messages from Fluent:

http://i43.tinypic.com/6okjle.png

Could you please somebody help or tell me what I need for right compile.

PS:sorry my english is bad :(

laurentb June 17, 2009 07:54

What compiler do you use ? you need a 32 bits compiler with fluent ntx86.

czfluent June 17, 2009 08:50

Im try to use windows c sdk ... but I dont know how its working ... please could you send me step by step how to compile ? ;)

laurentb June 17, 2009 09:25

1 Attachment(s)
See instructions in the pdf file attached

Microsoft C++
2008 Express Edition
which can be located at this link:
http://www.microsoft.com/downloads/d...DisplayLang=en

czfluent June 18, 2009 17:11

I have still same problem ... :mad:

los June 18, 2009 23:22

I ask myself why would you use a 32 bits fluent in a 64 bits environment...
Anyway it looks like you compiler is not set in the system path, that's why fluent cannot find it.
Try to concatenate you compiler directory at the system path, if it doesn't work, I think that Visual studio 2008 professional can compile 32 bits too, why don't you give it a try?

czfluent June 19, 2009 02:31

Quote:

Originally Posted by los (Post 219792)
I ask myself why would you use a 32 bits fluent in a 64 bits environment...
Anyway it looks like you compiler is not set in the system path, that's why fluent cannot find it.
Try to concatenate you compiler directory at the system path, if it doesn't work, I think that Visual studio 2008 professional can compile 32 bits too, why don't you give it a try?


Hi,

so now Im using fluent 6.3.26 with Windows XP 32b. What does you mean concatenate system path with compiler directory :confused: My system path for fluent:
C:\Program Files\Fluent.Inc
and
C:\Program Files\Microsoft Visual Studio 9.0\VC\

"Microsoft Visual Studio 2008
Version 9.0.30729.1 SP
Microsoft .NET Framework
Version 3.5 SP1
Installed Edition: VC Express
Microsoft Visual C++ 2008 91909-152-0000052-60589
"

Where I can compile file in Microsoft Visual C++ 2008 :confused:


Im try to use Interpreted UDFs from Fluent:


cpp -I"C:\PROGRA~1\Fluent.Inc\fluent6.3.26/src" -I"C:\PROGRA~1\Fluent.Inc\fluent6.3.26/cortex/src" -I"C:\PROGRA~1\Fluent.Inc\fluent6.3.26/client/src" -I"C:\PROGRA~1\Fluent.Inc\fluent6.3.26/multiport/src" -I. -DUDFCONFIG_H="<udfconfig.h>" "C:\working\man
alUDFexmaple_2.3.27_[ex1].c"
Error: C:\working\manualUDFexmaple_2.3.27_[ex1].c: line 51: structure reference not implemented

czfluent June 23, 2009 02:40

Could you help me please, anyone? ;)

When I try to load my case and data Fleunt answer me:

Building...
grid,
Cell Centroid is xc 3.733333 yc 0.200000
WARNING: no face with given nodes. Thread 2, cell 9
Error: Build_Grid: grid error.
Clearing partially read grid.

Error: Null Domain Pointer

Error Object: ()



But the other PC working ... maybe wrong install ?

czfluent July 7, 2009 16:02

so now I know why the FlUENT write me:

Building...
grid,
Cell Centroid is xc 3.733333 yc 0.200000
WARNING: no face with given nodes. Thread 2, cell 9
Error: Build_Grid: grid error.
Clearing partially read grid.

Error: Null Domain Pointer

Error Object: ()


I have a bad case data and files ... but still compile dont working ... :confused:

friends.sk July 8, 2009 16:21

Please Start Fluent from c++ command prompt.

It should work. best wishes.

czfluent July 26, 2009 15:09

Quote:

Originally Posted by friends.sk (Post 221966)
Please Start Fluent from c++ command prompt.

It should work. best wishes.

but, how to do that? please some screen? thank you!

laurentb July 30, 2009 03:59

1 Attachment(s)
print screen : visual c++ command prompt

then launch fluent, for example :
C:\Fluent.Inc\ntbin\ntx86\fluent.exe -r6.3.26

czfluent July 31, 2009 01:54

ok thank its working but ...



The system have not find this file ... or something like this write me fluent -...
(system "copy C:\PROGRA~1\Fluent.Inc\fluent6.3.26\src\makefile_n t.udf libudf\ntx86\2ddp\makefile")
1 copy file …
(chdir "libudf")()
(chdir "ntx86\2ddp")()

Done.
"c:/"



http://i32.tinypic.com/21o6jdc.png

Opening library "libudf"...
Error: open_udf_library: The system have not find this file ... :confused:

Error Object: ()

dahu007 August 18, 2009 07:10

Did you find a solution ? I have the same problem with visual C++ 2008 express !

czfluent August 21, 2009 04:06

Quote:

Originally Posted by dahu007 (Post 226674)
Did you find a solution ? I have the same problem with visual C++ 2008 express !


No, I have still problem with error ... :confused:
Please could you anyone help me ad my dahu007 ?

friends.sk August 21, 2009 04:26

I think your udf file is not in the same directory as your cas and data file. Pls. Check

czfluent August 21, 2009 05:04

Quote:

Originally Posted by friends.sk (Post 227048)
I think your udf file is not in the same directory as your cas and data file. Pls. Check


No I have ... look

http://i28.tinypic.com/el4rip.png

dahu007 August 21, 2009 05:12

I reinstaled Microsoft visual C++ and Nox it works !!

czfluent August 21, 2009 07:02

Quote:

Originally Posted by dahu007 (Post 227060)
I reinstaled Microsoft visual C++ and Nox it works !!


yes, me too.. still same problem ... :confused:

dahu007 August 22, 2009 15:31

when I instaled Microsoft visual C++ I picked all the option. You have to install microsoft.net framework 3.5 ans above all the msdn library !
Good luck !


All times are GMT -4. The time now is 14:24.