CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Fluent UDF and Scheme Programming

UDF parallel error: chip-exec: function not found?????

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 12, 2009, 18:48
Default UDF parallel error: chip-exec: function not found?????
  #1
New Member
 
Prashanth
Join Date: Apr 2009
Posts: 19
Rep Power: 7
shankara.2 is on a distinguished road
Hi all

I'm using a DEFINE_DPM_BC UDF on a wall in my domain. It's been running fine on serial for my previous cases. Even for parallel, I used the #if !RP_HOST and #endif commands within my UDF and it worked fine. I'm using the same UDF for a new case now.

When I run in parallel, I get the msg "Error:chip-exec: function 'none' not found'. I used some print statements inside my UDF to see if the UDF is getting executed but from what I see, FLUENT doesn't even go inside the UDF and none of the statements are printed. I'm guessing it's a problem with my parallel case. When I run the UDF in serial, it does get executed and I can see FLUENT passing through various stages of my UDF through the printed messages but after a while, I get the message 'Fluent process could not be started'.

What might be the problem here? I'm pretty sure nothing has changed in my system setup from when I ran my UDF successfully for my previous cases.
I did do something different but am not sure how much of an impact this will have on my UDF running correctly. Before I solved my flow field, I broke down the wall where the UDF will be applied into two. I used the Adapt-> Iso-value->Grid->Radial coordinate to mark some cells within a certain area on the wall and then used Separate->Faces to separate the wall into two regions and then solved my flow field. Now, the UDF is applied only to one region on my wall and I have reflect BC set on the other region. Not sure how much of a difference this will make.

Thanks

Prashanth
shankara.2 is offline   Reply With Quote

Old   January 16, 2012, 23:14
Default
  #2
New Member
 
A.Brusly Solomon
Join Date: Mar 2009
Posts: 2
Rep Power: 0
brusly is on a distinguished road
hi
Are you using UDMI in your UDF? If you are using UDMI,Please set User defined memory.
brusly is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile problem ivanyao OpenFOAM Running, Solving & CFD 1 October 12, 2012 09:31
udf compile in parallel system tahereh FLUENT 1 December 9, 2008 10:48
Parallel UDF problem Lindsay FLUENT 0 November 7, 2008 05:31
Axisymmetrical mesh Rasmus Gjesing (Gjesing) OpenFOAM Native Meshers: blockMesh 10 April 2, 2007 14:00
UDF in Parallel Gavin FLUENT 1 June 19, 2005 22:17


All times are GMT -4. The time now is 12:59.