CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Patching multifluid flow (http://www.cfd-online.com/Forums/fluent/102653-patching-multifluid-flow.html)

svanmunster May 30, 2012 22:01

Patching multifluid flow
 
Hi all,

I am having trouble initializing my multi-fluid vof model in Fluent. I am trying to simulate a simple open channel flow over a bump for a uni assignment.

My primary phase is air, and secondary phase in water. I am attempting to patch within fluent by adapt>region>mark, I then patch that region in initialization but when I view the volume fraction plot it is all the primary phase (air).

Is there something im missing?

Thanks

ghost82 May 31, 2012 04:05

Hi, make sure to:

- Adapt->Region.... Choose either Quad or Circle for 2D. Enter the Input Coordinates, and press Mark.
- In the Patch window, a new item just appeared, something like hexaedron. select this, write inputs and patch.

Daniele

mvee May 31, 2012 06:46

Patching multifluid flow
 
Hi svanmunster

Also make sure following -

If you mark the cells from secondary fluid side then define volume fraction 1 for secondary phase in that marked domain.

otherwise reverse the situation.

Regards
mvee

svanmunster May 31, 2012 07:10

Quote:

Originally Posted by ghost82 (Post 363981)
Hi, make sure to:

- Adapt->Region.... Choose either Quad or Circle for 2D. Enter the Input Coordinates, and press Mark.
- In the Patch window, a new item just appeared, something like hexaedron. select this, write inputs and patch.

Daniele

Hi thanks for the quick reply. Turns out I was doing it correctly but for one reason or another it didn't want to work. A quick ANSYS restart helped.

Another quick question if you dont mind. When viewing the volume fraction contour plot of the flow, there are values that are not equal to 1 or 0 but rather intermediate values. Does this mean that the water is mixing with the air??? That shouldnt be happening?

ghost82 May 31, 2012 07:17

Quote:

Originally Posted by svanmunster (Post 364020)
Hi thanks for the quick reply. Turns out I was doing it correctly but for one reason or another it didn't want to work. A quick ANSYS restart helped.

Another quick question if you dont mind. When viewing the volume fraction contour plot of the flow, there are values that are not equal to 1 or 0 but rather intermediate values. Does this mean that the water is mixing with the air??? That shouldnt be happening?

Yes I noticed that too.
A quick search on forum returns an old reply of amir:

Question:
When I patch a small volume I get an avaraged value of the specified parameter at the marginal grid of the volume. How can I avoid it?

answer:
it doesn't occur if you display cell values not node values. (you can set that in display->contour)

Daniele

svanmunster May 31, 2012 08:05

Quote:

Originally Posted by ghost82 (Post 364024)
(you can set that in display->contour)

Can't seem to find that option. Nevermind I can live with it (as long as fluent doesnt think it is mixing). If you dont mind danielle I have a further question in regards to viewing the velocity vectors/contours. With the multi-phase fluid I only have the option to view the velocity of the 'mixture' whereas I am only interested in the velocity of the water. Is there a way around this?

Thanks again!

ghost82 May 31, 2012 08:52

In the display->contour (the window where you choose "contours of.." and you click "display" to see contour) deselect "node values" and you will see only 0 / 1 vapor fraction.

Either in the display->contour you shoud see the option to change from mixture to phase-1 or phase-2 (choose velocity, then change from mixture to phase-1, assuming phase-1 is water).

Daniele

svanmunster May 31, 2012 17:54

http://img856.imageshack.us/img856/3302/cfdforum.jpg

I have uploaded a photo which shows my issues. As you can see there is no option to select anything other than 'mixture' in the drop down box. I have also unchecked node values in display but as you can see the volume fraction contour plot is still taking intermediate values.

Also, I am trying to simulate a hydraulic jump do you have any idea why the flow beyond the bump is not jumping?

Thanks again.

thermal energy March 14, 2014 12:14

Hello dear friends,

I try to simulate melting process using VOF model. Pcm is solid phase initialy. Upper part of the solid there is air. They do not mix eachother. he rectangular box is %85 full with solid pcm, %15 air. Natural convection is active. My primary phase air, secondary phase is pcm (phase change material). I have some questions to be sure about my model.

First, I do not define interface between air and pcm. Mean, There are 3 cell zone: air, fin ,pcm but I do not create name selection for this interface in meshing. Is it ok?

Initial condition of Wholesystem temperature is 293K, but air temp is 300K. how to set air temp ?

For cell zone condition, all cell zone (air, pcm, fin ) show mixture. Also for example, if I change pcm to phase2, all of cell zone change to phase 2

Only for secondary phase (pcm), I patch within fluent by adapt-region-mark then patch. Ok? Value of volume fraction should be 1 or 0 while patching?? I am confused. Initialy pcm is solid.

For initial values phase-2 volume fraction is 0. Ok?

I did some iteration for a short time to check model. For results, in graphics-countors I can not see total temperature for phase 1 and 2 only entalphy values I see for phase1 and 2.

Also countors of solidification/melting it shows only mixture. Mixture show what?

Any interaction should I use like surface tension etc.

Thanks for your help. ı am really in stuck. good work friends.

saddam May 4, 2014 12:37

can any one tell me how to plot velocity vector in multiphase??
when i m plotting it velocity of phase 1 it is not showing any thing in display but it is working with phase 2...


All times are GMT -4. The time now is 09:50.