CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Fluent reads mesh file well, but error when mesh checking

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 12, 2012, 10:25
Default Fluent reads mesh file well, but error when mesh checking
  #1
New Member
 
Ju Young Kang
Join Date: Jul 2012
Posts: 4
Rep Power: 4
jyoung79 is on a distinguished road
Hi,

I am developing a Cartesian grid generation program for Fluent, and I have generated a simple 2D Cartesian mesh with hanging nodes.

It can be read well in Fluent.

When, however, I check the mesh, 'mesh check failed' is happened.



I do not understand why the mesh failed.

I have attached the zipped mesh file (aa.zip) as well. Could you check my mesh file, and give an advice, please?
Attached Images
File Type: jpg bb.JPG (95.9 KB, 9 views)
Attached Files
File Type: zip aa.zip (698 Bytes, 3 views)
jyoung79 is offline   Reply With Quote

Old   November 13, 2012, 05:00
Default
  #2
Senior Member
 
Marion
Join Date: Jul 2012
Location: France
Posts: 122
Rep Power: 5
Marion is on a distinguished road
Hi,
I tried to read your mesh file but I get an error when fluent opens it:
Building...
mesh
Cell Centroid is xc -4.523810 yc 6.190476
WARNING: no face with given nodes. Thread 2, cell 3
Clearing partially read grid.
Error: Build Grid: Aborted due to critical error.
Error: Build Grid: Aborted due to critical error.
Error Object: #f
Marion is offline   Reply With Quote

Old   November 13, 2012, 05:06
Default
  #3
New Member
 
Ju Young Kang
Join Date: Jul 2012
Posts: 4
Rep Power: 4
jyoung79 is on a distinguished road
Hi,

Thank you very much for your reply.
Which Version do you use? Fluent 13 read the mesh just fine.
And I have found the fault on the mesh. Face tree was wrong.

Best regards,
jyoung79 is offline   Reply With Quote

Old   November 13, 2012, 05:50
Default
  #4
Senior Member
 
Marion
Join Date: Jul 2012
Location: France
Posts: 122
Rep Power: 5
Marion is on a distinguished road
Ah yes, I was still in V12, And I don't get the error with V13, which is weird!

I'm glad you found the problem.

Marion.
Marion is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
swak4foam building problem GGerber OpenFOAM 45 July 30, 2013 15:08
problem on installing swak4Foam navid2 OpenFOAM Installation 2 May 30, 2012 04:32
2.0.x on Mac OSX niklas OpenFOAM Installation on Windows, Mac and other Unsupported Platforms 74 March 28, 2012 16:46
Gerris software installation mer Main CFD Forum 2 November 12, 2005 08:50
error while compiling the USER Sub routine CFD user CFX 3 November 25, 2002 15:16


All times are GMT -4. The time now is 14:09.