CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Parallel processor

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 23, 2012, 07:45
Default Parallel processor
  #1
New Member
 
Arman
Join Date: Dec 2012
Posts: 8
Rep Power: 4
ArmanZohrabi is on a distinguished road
Hi boys!
I use fluent 6.3.26 and i find that FLUENT only use one core (13% of CPU). How could I make Fluent use all cores?
ArmanZohrabi is offline   Reply With Quote

Old   December 23, 2012, 15:28
Default
  #2
Member
 
Join Date: Dec 2012
Posts: 46
Rep Power: 4
jdrch is on a distinguished road
I'm not sure about version 6.*, but in 13*+ you enable multicore at the beginning of each session by selecting "Parallel" instead of "Serial" at the start.
jdrch is offline   Reply With Quote

Old   December 23, 2012, 16:53
Default
  #3
Senior Member
 
Lucky Tran
Join Date: Apr 2011
Location: Orlando, FL USA
Posts: 671
Rep Power: 13
LuckyTran will become famous soon enough
Quote:
Originally Posted by jdrch View Post
I'm not sure about version 6.*, but in 13*+ you enable multicore at the beginning of each session by selecting "Parallel" instead of "Serial" at the start.
Version 6 is identical to 12+ except the interactive window looks different (older).

In the interactive window choose "Parallel" or

If starting with scripts then you need to add -pe # to the script (parallel environment, # of cores)
LuckyTran is offline   Reply With Quote

Old   December 25, 2012, 10:28
Default
  #4
New Member
 
Fangdian
Join Date: Aug 2012
Posts: 19
Rep Power: 5
fangdian is on a distinguished road
Quote:
Originally Posted by LuckyTran View Post
Version 6 is identical to 12+ except the interactive window looks different (older).

In the interactive window choose "Parallel" or

If starting with scripts then you need to add -pe # to the script (parallel environment, # of cores)
IN FLUENT6.**, you can run fluent in parallel in this way: run the command: *fluent install directory*\fluent 3ddp -t2
(if its operation system is windows, and you want to use 2cores in CPU,3d,double precision in fluent)
fangdian is offline   Reply With Quote

Old   December 25, 2012, 17:53
Default
  #5
New Member
 
Arman
Join Date: Dec 2012
Posts: 8
Rep Power: 4
ArmanZohrabi is on a distinguished road
Quote:
Originally Posted by fangdian View Post
IN FLUENT6.**, you can run fluent in parallel in this way: run the command: *fluent install directory*\fluent 3ddp -t2
(if its operation system is windows, and you want to use 2cores in CPU,3d,double precision in fluent)
hi, thanks for your attention !
but i think that dp or double precision that you said isn't about cpu usage, it is about answer accuracy, isn't it ?
another thing is that my cpu is i7 and I want to parallel 4 cores by fluent 6.3.26
ArmanZohrabi is offline   Reply With Quote

Old   December 25, 2012, 18:33
Default
  #6
Member
 
Join Date: Dec 2012
Posts: 46
Rep Power: 4
jdrch is on a distinguished road
Quote:
Originally Posted by ArmanZohrabi View Post
another thing is that my cpu is i7 and I want to parallel 4 cores by fluent 6.3.26
If the interactive window for version 6 is identical to 12 as LuckyTran said, you should be able to select the number of parallel processes you want to use right after you select "Parallel."
jdrch is offline   Reply With Quote

Old   December 25, 2012, 18:53
Default
  #7
Senior Member
 
Lucky Tran
Join Date: Apr 2011
Location: Orlando, FL USA
Posts: 671
Rep Power: 13
LuckyTran will become famous soon enough
Quote:
Originally Posted by ArmanZohrabi View Post
hi, thanks for your attention !
but i think that dp or double precision that you said isn't about cpu usage, it is about answer accuracy, isn't it ?
The dp is there for another reason, you must launch Fluent in the intended environment. If you do not want double precision (who even uses single precision these days?) then you need to use 3d instead of 3ddp. If you want 2d then use 2d instead of 3d. But there must be an environment.

Quote:
Originally Posted by ArmanZohrabi View Post
another thing is that my cpu is i7 and I want to parallel 4 cores by fluent 6.3.26
It doesn't matter what cpu you have. Fluent version doesn't matter unless you have more than one Fluent installation.

If you want to do a 3d simulation, with double precision, AND 4 parallel threads then you need to use 3ddp -t4 (t is the number of threads)

If you only put -t4 (meaning you want 4 parallel threads) Fluent still does not know what the environment is and will not launch (i.e. 2d versus 3d, sp versus dp). Also note, the 3ddp must come before the # of threads you want to use.

Additional Examples:
all in serial environments
2d
2ddp
3d
3ddp

in parallel with # cpu's
2d - t#
2ddp -t#
3d -t#
3ddp -t#

Quote:
Originally Posted by ArmanZohrabi View Post
Hi boys!
I use fluent 6.3.26 and i find that FLUENT only use one core (13% of CPU). How could I make Fluent use all cores?
By the way, if you have a quad core then Fluent should be using up 25% of the cpu (i.e. 100% of 1 core). If it is running consistently at 13% then you have a memory bottleneck. Switching to a parallel environment will not do you any help if there is a memory bottleneck.
LuckyTran is offline   Reply With Quote

Old   December 27, 2012, 17:19
Default
  #8
New Member
 
Arman
Join Date: Dec 2012
Posts: 8
Rep Power: 4
ArmanZohrabi is on a distinguished road
Quote:
Originally Posted by LuckyTran View Post
The dp is there for another reason, you must launch Fluent in the intended environment. If you do not want double precision (who even uses single precision these days?) then you need to use 3d instead of 3ddp. If you want 2d then use 2d instead of 3d. But there must be an environment.



It doesn't matter what cpu you have. Fluent version doesn't matter unless you have more than one Fluent installation.

If you want to do a 3d simulation, with double precision, AND 4 parallel threads then you need to use 3ddp -t4 (t is the number of threads)

If you only put -t4 (meaning you want 4 parallel threads) Fluent still does not know what the environment is and will not launch (i.e. 2d versus 3d, sp versus dp). Also note, the 3ddp must come before the # of threads you want to use.

Additional Examples:
all in serial environments
2d
2ddp
3d
3ddp

in parallel with # cpu's
2d - t#
2ddp -t#
3d -t#
3ddp -t#


By the way, if you have a quad core then Fluent should be using up 25% of the cpu (i.e. 100% of 1 core). If it is running consistently at 13% then you have a memory bottleneck. Switching to a parallel environment will not do you any help if there is a memory bottleneck.

Thanks a lot man !!
ArmanZohrabi is offline   Reply With Quote

Old   March 10, 2013, 18:41
Cool easy way!
  #9
New Member
 
Arash zareinezhad
Join Date: Mar 2013
Location: Iran
Posts: 11
Rep Power: 4
a.zareinezhad is on a distinguished road
just right click in fluent icon in your desktop
in properties > shortcut tab > target

change
C:\Fluent.Inc\ntbin\ntx86\fluent.exe -r6.3.26
to:
C:\Fluent.Inc\ntbin\ntx86\fluent.exe -t6.3.26
now run the fluent
now you may see some message like this in fluent :

(Loading "C:\Fluent.Inc\fluent6.3.26\lib\fl114.dmp"
Done.
version>


now go to
file tab > run > and choose parallel type
in option > processes you can choose how many core do you want to use
be careful you should use one or 2 core less than your avalable core that your computer has.


a.zareinezhad is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Superlinear speedup in OpenFOAM 13 msrinath80 OpenFOAM Running, Solving & CFD 18 March 3, 2015 06:36
AMI speed performance danny123 OpenFOAM 19 October 24, 2012 07:44
problems after decomposing for running alessio.nz OpenFOAM 5 April 20, 2011 08:44
DecomposePar unequal number of shared faces maka OpenFOAM Pre-Processing 6 August 12, 2010 09:01
IcoFoam parallel woes msrinath80 OpenFOAM Running, Solving & CFD 9 July 22, 2007 02:58


All times are GMT -4. The time now is 19:54.