CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Boundary conditions (http://www.cfd-online.com/Forums/fluent/113419-boundary-conditions.html)

Roby_1986 February 19, 2013 11:34

Boundary conditions
 
1 Attachment(s)
Hi everybody,
I'm studying, with Fluent, the natural ventilation of a cubic building in a huge fluid domain (as shown in figure) over a basis representing the ground.
I've some problems in setting boundary conditions, infact I've formulated within the Meshing of Workbench some "Named Selections", specifically:Velocity inlet 1, velocity inlet 2, velocity inlet 3,velocity inlet 4 and pressure outlet for all the faces of the domain except the floor; moreover I've set the name of all the surfaces of the walls of the building (front, back, left, right and roof, both internal and external) since I've divided all the building walls in many parts in order to have sweapable bodies during meshing.

In Fluent I have 3 "Cell Zone Conditions": building, domain and ground.
However, setting boundary conditions, Fluent has created many further walls (and shadow walls) which can't be seen in dispaying mesh surfaces but are the only walls that can be edited in the window of Boundary Conditions.
Which could be the problem?I've tried to delete the additional walls in "surface manage" but the situation persists.
Bests

RodriguezFatz February 19, 2013 11:57

Hi, did you create several parts? I guess what you want is to create multiple bodies and group these bodies to a single part. If you do the second, the grid at the transitions is conformal, i.e. all faces from one body match exactly the faces of the adjacent body. I think the meshing tool made non-conformal transitions and thus needs all these dizzying shadow faces!
Go back to DesignModeler and put all your bodies into one part: mark the bodies in the lowest part on the left ("tree outline") and click on "form new part". I hope your problems will vanish then...

Roby_1986 February 21, 2013 13:31

Hi,
Thanks for the reply. Indeed I've unify all the bodies under just one part and now I've no problems in setting boundary conditions. But when I try to run, after few iterations I get this message: "Error: Divergence detected in AMG solver: epsilon". It is possible linked to a problem related to the high aspect ratio of feww elements which is reported by Fluent when I check the mesh. However I don't know how to manage this problem, since aspect ratio is very high just in few cells that I can see in the Mesher of Workbench. I don't know how to improve it within these cells and if I've to do this in Fluent or in the mesher (and how).
Any suggestion?
Thanks a lot.
Bests

RodriguezFatz February 21, 2013 14:19

I guess you use the Ansys Meshing uitlity. If you had ICEM-hexa for meshing, I could help you...
Can you post a picture of the mesh? Or you start a thread in the meshing sub-forum.


All times are GMT -4. The time now is 18:47.