CFD Online URL
[Sponsors]
Home > Forums > FLUENT

Error: FLOAT: invalid argument [1]: wrong type [not a number]

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 26, 2013, 10:02
Default Error: FLOAT: invalid argument [1]: wrong type [not a number]
  #1
New Member
 
Burak SUNAN
Join Date: Dec 2012
Posts: 8
Rep Power: 3
brksnn is on a distinguished road
Hello guys,

I am getting the following error with ANSYS Fluent 14.5 x64 in Win7 Home Basic. Firstly, I searched the similar errors from this forum and also from google. I found a few responses, not a specific answer.

Some of them is relevant to re-mesh.
Somebody says close Fluent and re-open Fluent. (The ANSYS Support team response )

I tried the these responses. I have changed my mesh four or five times. I re-check my geometry and my mesh skewness. I closed and re-opened Fluent, too. I changed boundary conditions. I have changed some solution options. However, I couldnt figure out the solution for this error.

Last week, I got good calculations from similar geometry and same options in Fluent. Two weeks ago, I got the same error and I remeshed and solved the problem, but it doesnt work this time.

Now, I am getting this error. I am looking forward to your helpful responses.

-------------------------------------------------
Error: cx-xy-plot-data: invalid number
Error Object: 1.#inf

Error: cx-xy-plot-data: invalid number
Error Object: -1.#inf

Error: cx-xy-plot-data: invalid number
Error Object: 1.#inf
step flow-time Cm-1 Cl-1 Cd-1
1 3.0000e-02
Error: FLOAT: invalid argument [1]: wrong type [not a number]
Error Object: 1.#inf
----------------------------------------------------
brksnn is offline   Reply With Quote

Old   February 27, 2013, 03:35
Default
  #2
Senior Member
 
Saeed Sadeghi
Join Date: Oct 2012
Location: Denmark
Posts: 227
Rep Power: 5
msaeedsadeghi is on a distinguished road
haha.
Seems better to restart fluent.
__________________
Regards,
Saeed Sadeghi
Ansys Fluent CFD Consultant
msaeedsadeghi is offline   Reply With Quote

Old   February 27, 2013, 05:08
Default
  #3
New Member
 
Burak SUNAN
Join Date: Dec 2012
Posts: 8
Rep Power: 3
brksnn is on a distinguished road
Hi Saeed Sadeghi,

I want to also share my experience last night with same error. I checked the previous calculations which are same geometry but smaller domain and solved with 5000 iterations in transiet time. I maintained the calculation with 50 iterations. It didnt give any error, also calculated the drag, lift coefficients.

After this calculation, I duplicated the fluent in workbench and just changed the time to steady from transiet. I didnt changed anything, and it gave me the same error. Besides, it happens in another computer.

Please, any ideas....?
brksnn is offline   Reply With Quote

Old   August 17, 2013, 16:39
Default Error: FLOAT: invalid argument [1]: wrong type [not a number] SOLUTION
  #4
New Member
 
Jules
Join Date: Aug 2013
Posts: 1
Rep Power: 0
TheDouglasDale is on a distinguished road
I had the exact same problem. You have set a moment coefficient monitor, which requires both a projected area, as well as a characteristic length, in the Reference Values options. My problem was that the characteristic length was set to zero. Make sure that both the characteristic length and project areas of your simulation are not zero. I'm assuming that you're simulating an external flow? Hope this helps.
TheDouglasDale is offline   Reply With Quote

Old   August 25, 2013, 19:51
Default
  #5
New Member
 
H Liu
Join Date: Jan 2013
Posts: 3
Rep Power: 3
cfdhrl is on a distinguished road
Hi, brksnn,
I also came across this problem. I solve according the following idea. good luck
Error: CDR: invalid argument [1]: wrong type [not a pair];Error Object: #f
cfdhrl is offline   Reply With Quote

Reply

Tags
argument, error, float, fluent, invalid

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
interFoam/kOmegaSST tank filling with printStackError/Mules simpomann OpenFOAM Running, Solving & CFD 3 February 17, 2014 18:06
Compiling dynamicTopoFvMesh for OpenFOAM 2.1.x Saxwax OpenFOAM Installation 25 November 29, 2013 06:34
[GAMBIT] periodic faces not matching Aadhavan ANSYS Meshing & Geometry 6 August 31, 2013 12:25
Problems with Turbulence Modeling ezsoal OpenFOAM Running, Solving & CFD 4 November 26, 2009 16:12
error: CDR: invalid argument [1]: wrong type Marc FLUENT 0 July 24, 2006 06:59


All times are GMT -4. The time now is 02:40.