CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   rotation inconsistent error (

manjunath June 2, 2013 20:01

rotation inconsistent error
1 Attachment(s)

I am trying to simulate flow in a stirred tank using symmetry assumption. I am considering only half volume(180 section of the tank). I am able to successfully create periodic faces in Fluent for rotating and stationary zones. But, fluent is not able to get the correct rotation angle and gives error everything I do mesh check (attached image).

I specify the rotational periodicity in ICEM with proper angle and rotation axis. I have tried rotating the geometry and mesh in ICEM and Fluent but I still get the error but the "average rotation angle" changes. I have attached the screenshot of the error message.

Can someone please help me with this issue. I have been struggling with this for the last 2 weeks without knowing the cause of the error.


RodriguezFatz June 3, 2013 05:18

I always create a "normal" mesh in ICEM, without bothering ICEM with any periodicity. This takes all place in Fluent and I never had any problem like this. Maybe you should try: Switch off all periodic stuff in ICEM and just name the relevant surfaces. Export to fluent and do everything here.

manjunath June 3, 2013 14:27

I did try doing that but still got the same error. BTW, I was able to set up the problem in Fluent despite the error. I will proceed with the simulation and see if it makes any difference to the results. Thanks for your reply.

RodriguezFatz June 4, 2013 02:57

How do you set up Fluent? With "make-periodic" in the terminal?
Maybe your mesh isn't conformal, i.e. the cell faces don't fit together...

manjunath June 4, 2013 14:48

I use the make-periodic TUI to set up the periodic faces. The faces are conformal and the number of cells on both the faces match exactly. Infact, I was able to set up and the run the case for 120 degree section earlier. But, when I started out with 180 degree section I started facing the average rotation issue in Fluent. I have run out of things to change on ICEM and Fluent side to see where the problem is. I suspect the periodic faces lying on a straight line might cause rotation problem, but people have simulated such problems before so I am not sure.

RodriguezFatz June 5, 2013 03:50

Did you run "make-periodic" with and without automatic angle detection?

manjunath June 5, 2013 11:53

I think it would be without automatic angle detection. I use the following commands: define> boundary-conditions> modify-zones> make-periodic>
followed by zone names.
I have not come across the make-periodic option with and without automatic angle detection in Fluent. Can you tell me the exact command or post a link so that I can read more about it. Thanks for your response.

ghost82 June 5, 2013 12:41

first of all, but I think it's a typo, symmetry condition is not good, as you have to use periodic condition.
I had also these problems in the past, check:
1- in pre-processor the rotation axis: I remember in the past I had the axis not perfectly centered in 0,0,0, but something like 10^-7,0,0: copy these values into fluent for axis origin
2- so, in fluent the rotation axis is set up properly


manjunath June 5, 2013 12:49

Hi Daniele,

What I meant by symmetry was that I would be using periodic conditions and use only half of the tank volume because of the flow symmetry. I created the periodic faces as walls in ICEM and used Fluent to assign periodicity using make-periodic.
I will check to make sure I am assigning the rotation axis origin properly in ICEM and Fluent. Thanks for your help.


RodriguezFatz June 6, 2013 01:56

Manjunath, I only use translational symmetry, but I am asked by fluent whether I want to auto-detect the offset or put it in by hand. (during the "make-periodic"). Your respond sounds like fluent doesn't ask you...

Why don't you upload the ICEM files?

manjunath June 6, 2013 12:16

Here is the link for geometry and blocking files for rotor and stator zones.


I checked to make sure I was entering the correct values for origin and axis but I got a similar error again.


RodriguezFatz June 7, 2013 04:13

error in xxx.tin
can't read surface model.

Any ideas? I use Icem 14.5.

RodriguezFatz June 12, 2013 05:23

Alright, as I said, I only had translational periodicity before, but it seems that in Fluent you need the periodic axis to be the z-axis. Once I rotated the blocks and geometry I could use "make-periodic". Also, I had problems to import the mesh, when faces were called "periodic-blabla". I changed their name to "pe-blabla" and it worked.

All times are GMT -4. The time now is 07:02.