CFD Online Logo CFD Online URL
Home > Forums > FLUENT

[Linux] Minor problem with flexlm lmgrd process

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   October 19, 2013, 10:48
Default [Linux] Minor problem with flexlm lmgrd process
Senior Member
ghost82's Avatar
Join Date: Oct 2010
Location: Italy
Posts: 949
Rep Power: 15
ghost82 will become famous soon enough
Hi my friends!

I'm planning to migrate from windows 7 64 bit to linux 64 bit: I use fluent and gambit and my current setup is to run fluent in windows 7 with an hpc license for 12 processors and gambit inside a linux 64 bit virtual machine to have all the 64 bit for meshing.
However I can install fluent directly in linux 64 bit, so to avoid the virtual machine I'm planning this migration.

After about 2 days I was able to run Fluent 14.5.7 on kubuntu 64 bit; all is ok, license is correctly read.

However I have a minor problem:
when I reboot or start the os the license server is not started (licensing interconnect, licensing interconnect monitor and flexlm).
After starting /usr/ansys_inc/shared_files/licensing/lic_admin/anslic_admin I can see all the 3 "not running".
When I click on "start the ansys inc license manager" licensing interconnect and licensing interconnect monitor show as running but not flexlm.
With the command ps -A to list all the processes I have 2 lmgrd processes running:

2806 ?        00:00:02 ansysli_server
2812 ?        00:00:00 ansysli_monitor
2816 ?        00:00:00 lmgrd
2895 ?        00:00:00 lmgrd
If I kill the first lmgrd (sudo kill 2816) then on anslic_admin window flexlm turns on running and all work!

Why lmgrd starts 2 times?(before clicking on "start the ansys inc license manager" ps -A shows no lmgrd processes)

How can I automatically and correctly start the license server?

Thank you!


making a sh file in sbin folder and start at boot doesn't work (licensing interconnect and licensing interconnect monitor are running but not flexlm)
ghost82 is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
License trouble: ANSLIC_ADMIN, FLEXlm not running, but two lmgrd processes running! dancoz87 ANSYS 13 October 3, 2015 03:13
License Error lffabiani CFX 2 June 30, 2011 20:51
problem with starting ansyslmd Mike CFX 0 March 2, 2005 08:59

All times are GMT -4. The time now is 05:00.