CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

How to find cells whose skewness exceed 0.98 in Fluent?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 8, 2014, 02:50
Default How to find cells whose skewness exceed 0.98 in Fluent?
  #1
Member
 
Sangwoo Kim
Join Date: Jul 2014
Location: Seoul, South Korea
Posts: 94
Rep Power: 3
swtbkim is on a distinguished road
Hi all!

I made a grid and imported it in fluent and checked case before running calculation

But an error occurred as follows:
Skewness exceeded 0.98 at 3 cells on thread ID = 2.


I want to know the coordinates of these cells in Fluent in order to correct
How should I do?

or, is there another easier way to correct it?


Thanks in advance!
__________________
Best regards
swtbkim is offline   Reply With Quote

Old   August 8, 2014, 05:37
Default
  #2
Senior Member
 
Cees Haringa
Join Date: May 2013
Location: Delft
Posts: 307
Rep Power: 6
CeesH is on a distinguished road
Hi,

There are a few things you could do. Of course, you could go back to your mesher, check the cells out there, and restructure your mesh in the affected area. This is the advisable solution, because it allows you the most control over what happens to your mesh.

Another option is to fix it in FLUENT itself. You can use adapt/iso-value to select cells that have a skewness or quality value below a certain treshold. Clicking `adapt' will cause fluent to remesh this cells with a finer mesh, which may take away the problem (but it is not guaranteed to do so).

Hope that helps!
Cees
CeesH is offline   Reply With Quote

Old   August 8, 2014, 10:23
Default
  #3
Member
 
Hooman
Join Date: Feb 2012
Location: USA
Posts: 77
Rep Power: 5
enayath is on a distinguished road
Sangwoo,

I suggest to fix it in mesh section(before import it in Fluent)
In mesh, go to mesh and then click on Statistics and then open the skewness tab and then see where are the worst elements and then try to have a better mesh there

Good Luck,
Hooman
enayath is offline   Reply With Quote

Old   August 10, 2014, 21:54
Default
  #4
Member
 
Sangwoo Kim
Join Date: Jul 2014
Location: Seoul, South Korea
Posts: 94
Rep Power: 3
swtbkim is on a distinguished road
Quote:
Originally Posted by CeesH View Post
Hi,

There are a few things you could do. Of course, you could go back to your mesher, check the cells out there, and restructure your mesh in the affected area. This is the advisable solution, because it allows you the most control over what happens to your mesh.

Another option is to fix it in FLUENT itself. You can use adapt/iso-value to select cells that have a skewness or quality value below a certain treshold. Clicking `adapt' will cause fluent to remesh this cells with a finer mesh, which may take away the problem (but it is not guaranteed to do so).

Hope that helps!
Cees

Thank you for your suggestion!
I will try and leave a feedback.
__________________
Best regards
swtbkim is offline   Reply With Quote

Old   August 10, 2014, 21:57
Default
  #5
Member
 
Sangwoo Kim
Join Date: Jul 2014
Location: Seoul, South Korea
Posts: 94
Rep Power: 3
swtbkim is on a distinguished road
Quote:
Originally Posted by enayath View Post
Sangwoo,

I suggest to fix it in mesh section(before import it in Fluent)
In mesh, go to mesh and then click on Statistics and then open the skewness tab and then see where are the worst elements and then try to have a better mesh there

Good Luck,
Hooman

You mean in ICEM? I don't know about statistics option.
Unfortunately I use pointwise and I have never been using ICEM...
__________________
Best regards
swtbkim is offline   Reply With Quote

Old   August 10, 2014, 22:14
Default
  #6
Member
 
Sangwoo Kim
Join Date: Jul 2014
Location: Seoul, South Korea
Posts: 94
Rep Power: 3
swtbkim is on a distinguished road
Quote:
Originally Posted by CeesH View Post
Hi,

There are a few things you could do. Of course, you could go back to your mesher, check the cells out there, and restructure your mesh in the affected area. This is the advisable solution, because it allows you the most control over what happens to your mesh.

Another option is to fix it in FLUENT itself. You can use adapt/iso-value to select cells that have a skewness or quality value below a certain treshold. Clicking `adapt' will cause fluent to remesh this cells with a finer mesh, which may take away the problem (but it is not guaranteed to do so).

Hope that helps!
Cees

Iso-value is not activated in Adapt tab..
What can I do?
__________________
Best regards
swtbkim is offline   Reply With Quote

Old   August 11, 2014, 02:45
Default
  #7
Member
 
Sangwoo Kim
Join Date: Jul 2014
Location: Seoul, South Korea
Posts: 94
Rep Power: 3
swtbkim is on a distinguished road
Quote:
Originally Posted by CeesH View Post
Hi,

There are a few things you could do. Of course, you could go back to your mesher, check the cells out there, and restructure your mesh in the affected area. This is the advisable solution, because it allows you the most control over what happens to your mesh.

Another option is to fix it in FLUENT itself. You can use adapt/iso-value to select cells that have a skewness or quality value below a certain treshold. Clicking `adapt' will cause fluent to remesh this cells with a finer mesh, which may take away the problem (but it is not guaranteed to do so).

Hope that helps!
Cees
Oh never mind. I found it.

But How can I remesh?
Can you explain more detailed procedure?
__________________
Best regards
swtbkim is offline   Reply With Quote

Old   August 11, 2014, 05:05
Default
  #8
Senior Member
 
Cees Haringa
Join Date: May 2013
Location: Delft
Posts: 307
Rep Power: 6
CeesH is on a distinguished road
I think you need to do 1 iteration before it becomes available.
Then go to adapt -> iso value -> mesh
there you can select the property you want to adapt; so skewness, orthogonal quality, etcetera.
If you click `compute' the minimum and maximum value of the property in the domain are shown. Then you can set the minimum and maximum bounds; the setup will select all cells between these bounds. For example, you can set skewness with min 0.7 and max 1.0 to select all cells with a skewness bigger than 0.7.

Click adapt to remesh them. But again; it would be better to go back to your meshing programme and adapt the mesh there rather than in fluent if that is a possibility for you.
CeesH is offline   Reply With Quote

Old   August 11, 2014, 05:29
Default
  #9
Member
 
Sangwoo Kim
Join Date: Jul 2014
Location: Seoul, South Korea
Posts: 94
Rep Power: 3
swtbkim is on a distinguished road
Thank you very much!
I will try.

I want to adapt in fluent because doing it in mesher is too difficult...
I needed some automatic function lol
I wish it works
__________________
Best regards
swtbkim is offline   Reply With Quote

Old   August 11, 2014, 20:13
Default
  #10
Member
 
Hooman
Join Date: Feb 2012
Location: USA
Posts: 77
Rep Power: 5
enayath is on a distinguished road
Sangwoo,

No I meant in workbench-->Fluid Flow-->Mesh-->
and the rest of my suggestion.

Hooman
enayath is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Foam::error::PrintStack almir OpenFOAM Running, Solving & CFD 59 February 8, 2016 20:18
snappyhexmesh remove blockmesh geometry philipp1 OpenFOAM Running, Solving & CFD 2 December 12, 2014 11:58
[ICEM] Cells have only wall faces error in Fluent Sparsh6 ANSYS Meshing & Geometry 0 March 18, 2014 06:31
Problem with divergence TDK FLUENT 10 September 8, 2012 01:11
CFX problem in ubuntu (linux) Vigneshramaero CFX 0 July 13, 2012 10:22


All times are GMT -4. The time now is 15:35.