CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Fluent Licensing issue

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 18, 2014, 11:37
Default Fluent Licensing issue
  #1
New Member
 
Rachel
Join Date: Oct 2014
Posts: 5
Rep Power: 3
rbgamblin is on a distinguished road
Hello all,

I recently got a Student ANSYS 15 license (June) and I registered it on my laptop. I run the Licensing Utility and I get the attached licensing error.

Even though when I run the license wizard, I select the license file (on the desktop of my laptop, the same machine on which I am trying to run ANSYS Fluent) and it says "no new license found, so not installing a new license."

I know this is an Ansys issue, but they don't provide technical support for Student licenses, except for an FAQ that just tells me to refer to an advanced licensing guide which I can't find.
http://www.ansys.com/Support/Licensi...icensing+Guide

And this is what they give me in the help files installed on my laptop, after I try to set the License Preferences for User Abyss, and trying to select version 15:
Quote:
License Preferences

You are seeing this error message because the license preferences could not be retrieved. In some cases, you can resolve this problem by trying the following:
  1. Verify that you have correctly specified the license server machine. You can check this by opening the Client ANSLIC_ADMIN utility and choosing Specify the License Server Machine. Verify that:
    1. A license server machine is specified.
    2. You have access to the specified machine(s).
    3. The license server machine is running and the license server has been started correctly.
  2. Verify that license file has been cached if the FlexNet and ANSYS Licensing Interconnect components were started separately. See Advanced Licensing Configuration Options in the ANSYS, Inc. Licensing Guide for more information on running the licensing components independently.
Since ANSYS won't answer my phone calls, I am turning to the community for help.



I have a hunch that somehow when I installed the ANSYS package, it got set up so that the "FlexNet and ANSYS Licensing Interconnect components" get started separately, and one or the other isn't actually being started because I have no idea what those two things are.
If that's the case, does anyone know how I "verify that the license filed has been cached"?
Attached Images
File Type: jpg license error.jpg (56.3 KB, 7 views)
rbgamblin is offline   Reply With Quote

Old   November 18, 2014, 23:44
Default
  #2
Senior Member
 
Lucky Tran
Join Date: Apr 2011
Location: Orlando, FL USA
Posts: 1,270
Rep Power: 20
LuckyTran will become famous soon enough
Btw, did you remember to install with admin privileges?
Also, make sure you are running ANSLIC_ADMIN utility with admin privileges. Most of the options will be disabled if you are not admin.

To verify if licenses are working properly. Go to view status/diagnostics option and click display the license status.

I also have always have an issue with the license server after a restart. I have to manually stop and start the license manager or it does not work.
LuckyTran is offline   Reply With Quote

Old   November 20, 2014, 11:28
Default
  #3
New Member
 
Rachel
Join Date: Oct 2014
Posts: 5
Rep Power: 3
rbgamblin is on a distinguished road
Yes, I am logged into the administrator account on my laptop (the only account available), and even when I right-click-to-run as Administrator on "Client ANSLIC_ADMIN Utility 15.0" I still have most of the options blocked out.

I cannot manually stop and start the License Manager because that option is blocked out. And when I get it to allow me to run the License Wizard, the process fails because it says that it cannot stop the License Manager (since the wizard tries to stop and start it), but it does not state WHY it cannot stop the License Manager.

Edit:
When I "Display the License Status" the utility does this output:
Quote:
***** LICENSE SERVER STATUS: 1055@Abyss-HP *****


lmutil - Copyright (c) 1989-2013 Flexera Software LLC. All Rights Reserved.
Flexible License Manager status on Thu 11/20/2014 09:29

[Detecting lmgrd processes...]
License server status: 1055@Abyss-HP
License file(s) on Abyss-HP: C:\Program Files\ANSYS Inc\Shared Files\Licensing\license.dat:

Abyss-HP: license server UP (MASTER) v11.11

Vendor daemon status (on Abyss-HP):

ansyslmd: UP v11.11
Feature usage info:

Users of aa_t_i: (Total of 1 license issued; Total of 0 licenses in use)
rbgamblin is offline   Reply With Quote

Old   November 20, 2014, 15:29
Default
  #4
Senior Member
 
Lucky Tran
Join Date: Apr 2011
Location: Orlando, FL USA
Posts: 1,270
Rep Power: 20
LuckyTran will become famous soon enough
There are two shortcuts:

If you are seeing Client ANSLIC_ADMIN Utility then that means you do not have the license server software installed on your machine. That is, you do not have a license server setup.

The correct shortcut is Server ANSLIC_ADMIN Utility.

The license server installation is done separately from the rest of Fluent & Ansys products. But the files are on the same installation disc, iso, or package that you have (run setupLM.exe instead of setup.exe)

Maybe you already have it installed, but make sure you are running Server ANSLIC_ADMIN Utility and not Client. The client utility does not give you the server options because it is not a utility for running the server, it only controls the client.
LuckyTran is offline   Reply With Quote

Old   November 20, 2014, 17:39
Default
  #5
New Member
 
Rachel
Join Date: Oct 2014
Posts: 5
Rep Power: 3
rbgamblin is on a distinguished road
Eureka!

That has significantly clarified my issue. I ran setupLM.exe and successfully installed Server ANSLIC_ADMIN Utility.

It does look like I will have to do this frequently, whenever I:
1. Right click, Run-As-Administrator on "Server ANSLIC_ADMIN Utility"
2. Run License wizard (where I skip the first two steps, because my license is the same, and my server is the same) and it Successfully (finally!) Stops and then Starts the License Manager.

Hoorah! Thanks so much. Now I definitely understand how to fix my problem, and I kind of understand what the actual problem is.
rbgamblin is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error in reading Fluent 13 case file in fluent 12 apurv FLUENT 2 July 12, 2013 07:46
Gambit + Fluent Issue Heat Pipe FLUENT 0 November 3, 2011 14:58
Gambit + Fluent Issue Heat Pipe ANSYS 0 November 3, 2011 14:49
Grid-checking issue in Fluent Vince FLUENT 3 December 4, 1999 22:56
Fluent 5.0 boundary condition issue with RSM Flav Main CFD Forum 2 October 20, 1999 04:57


All times are GMT -4. The time now is 17:37.