CFD Online Logo CFD Online URL
Home > Forums > FLUENT

MPI for FLUENT Parallel

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   April 22, 2015, 09:51
Question MPI for FLUENT Parallel
New Member
Zhiteng Gao
Join Date: Apr 2015
Posts: 2
Rep Power: 0
Gordon00392157 is on a distinguished road
My boss bought a new workstation with 24 cores/48 threads, windows server 2012 R2, Ansys Fluent 16.0.
If I use 46 threads in parallel processing, all the logical CPUs are running.Total CPU utilization is about 115%.
If I use 48 threads, Total CPU utilization is about 80%.About 5-6 logical CPUs utilization is 10%, but it's fast than 46 threads.
How can I use all the logical CPUs with 100% utilization at 48 threads?
Is that influenced by different MPI version?
By the way, in my own computer, the default MPI is pcmpi; but in the workstation, the default MPI is intel mpi.Why?
Gordon00392157 is offline   Reply With Quote

Old   April 22, 2015, 10:06
Senior Member
ghost82's Avatar
Join Date: Oct 2010
Location: Italy
Posts: 950
Rep Power: 15
ghost82 will become famous soon enough
Did you try to disable the hyperthreading in bios and running your simulation in only 24 physical cores?
I'm quite sure it will be faster..check the hardware section of this forum for benchmarks.
About mpi, just use one of the options. It should not affect simulation time.
Google is your friend and the same for the search button!
ghost82 is online now   Reply With Quote

Old   April 23, 2015, 05:00
New Member
Zhiteng Gao
Join Date: Apr 2015
Posts: 2
Rep Power: 0
Gordon00392157 is on a distinguished road
Thank you for your advice!
I searched "hyperthreading" in Ansys Help 16.0, then I found this:
"ANSYS does not recommend using hyperthreading technology in conjunction with ANSYS CFD Solvers. We recommend that you turn CPU hyperthreading off."
I will try it on my workstation, thank you again.
Gordon00392157 is offline   Reply With Quote


mpi parallel

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
simpleFoam parallel AndrewMortimer OpenFOAM Running, Solving & CFD 12 August 7, 2015 18:45
problem during mpi in server: expected Scalar, found on line 0 the word 'nan' muth OpenFOAM Running, Solving & CFD 2 April 10, 2015 05:42
HP MPI warning...Distributed parallel processing Peter CFX 10 May 14, 2011 06:17
Error using LaunderGibsonRSTM on SGI ALTIX 4700 jaswi OpenFOAM 2 April 29, 2008 10:54
Is Testsuite on the way or not lakeat OpenFOAM Installation 6 April 28, 2008 11:12

All times are GMT -4. The time now is 10:38.