CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   FIDAP on glibc 2.1 (

Ingo Meisel January 31, 2002 12:03

FIDAP on glibc 2.1

is there anybody who has tried to get FIDAP up and running on a Linux system with glibc 2.2 even though FIDAP requires glibc 2.1? I am very much interested in solutions to this compatibility problem!

Thanks in advance,


Markus January 31, 2002 18:38

Re: FIDAP on glibc 2.1
Hallo Ingo,

I have heared that there is no problem to use FIDAP8.6.2 with glibc2.2 (SUSE7.1). It is rather a problem to GAMBIT1.3 or FLUENT5. Did You installed it and got into trouble?



Ingo Meisel February 1, 2002 06:15

Re: FIDAP on glibc 2.1

thanks for your quick answer. Yes I have experienced problems after installing FIDAP 8.6.2 on a dual CPU Red Hat 7.2 system (glibc 2.2.4). FLUENT wants you to install FIDAP on a Red Hat 6.0 system with glibc 2.1, but the hardware is too new. As long as no user-defined subroutines are incorporated (which implies re-compiling FIDAP and/or FISOLV executables) the program seems to work *more or less* error-free, e.g. I had FIDAP solve example 3 of the manual without trouble. But most of the the shared libraries are the wrong version (ldd -v fidap/fisolv). Using compatibility libraries plus an old compiler version and $LD_LIBRARY_PATH/$LD_PRELOAD/$LDEMULATION/$GCC_EXEC_PREFIX should work around the problems, but so far I haven't managed to deal with all that.

Always grateful for hints,

Ingo Meisel

All times are GMT -4. The time now is 19:20.