CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   UDF (http://www.cfd-online.com/Forums/fluent/29327-udf.html)

Rahul February 6, 2002 00:38

UDF
 
Hi everybody, I am trying udse complied UDF. I am using Window NT4.00 I have created very simple udfs and made all directories as per help manual instructions.

When I type nmake in build directory I get this message. The name specified is not recognized as an internal or external command, operable program or batch file.

Then when I write libudf in Flunet in Define-> User-Defined->Functions->Compiled I am getting this error

Opening library "libudf"... trying library "libudf.dll" trying library "libudf\ntx86\3d\libudf.dll" trying library "libudf\ntx86\libudf.dll" Error: open_udf_library: The system cannot find the path specified.

Can anyone help me for this. Rahul


Greg Perkins February 6, 2002 23:37

Re: UDF
 
you have not actually compiled, due to the problem with nmake.

You need to ensure you path points to the compiler directory, where the nmake command is located.

Alternatively, type (form memory - so is not quite right, something like:)

\Program Files\Microsoft_Studio\VC98\Bin\nmake

This is not the right path, but if you do a find files under Windows for nmake* you should be able to determine it pretty quickly for your system

Greg

Rahul February 7, 2002 00:33

Re: UDF
 
Thanks greg, It was problem with nmake. Now my problem is I am getting this error when I type nmake in build directory (i.e 3d), fatal error c1083: Can not include file : "stdrag.h' : No such file of directory

Is it because of wrong setting of path ?

Rahul

Greg Perkins February 7, 2002 00:45

Re: UDF
 
Not sure. You need to follow the Fluent directions exactly when using Windows. ...I know its not that clear, because I had to do it once...personally I prefer unix/linux if there's a choice.

Looks like a path problem, but can't be sure. Did you try just from the command line like I suggested??

Greg

Rahul February 7, 2002 02:35

Re: UDF
 
Hi greg, I have given correct path for nmake. Now I am not facing problem becuase of nmake but I think becuase of compiler for c/c++. Shall I reload visual c++ with set path atomatically option ? In my computer paths for others are not created. I think it could be a reason. Rahul


gokulgech January 3, 2014 09:38

udf
 
Hi everybody, I am trying udse complied UDF.
When I type nmake in build directory I get this message. The name specified is not recognized as an internal or external command, operable program or batch file.

Then when I write libudf in Flunet in Define-> User-Defined->Functions->Compiled I am getting this error

Opening library "libudf"... trying library "libudf.dll" trying library "libudf\ntx86\3d\libudf.dll" trying library "libudf\ntx86\libudf.dll" Error: open_udf_library: The system cannot find the path specified.

i am using windows 8, 64-bit. Pls sugest how to set path and environment also which Microsoft visual studio and sdk to instal


Can anyone help me for this. gokul[/QUOTE]
thank you

shuai_manlou January 4, 2014 21:30

First of all, what is the edition of your Flent and your Visual studio ? Fluent 12,13 and 14 requires visual studio 2008 to 2012.
Second, you should set your computers enviroment correct. You can search the nmake.exe in your computer, and copy the path to the enviroment variables.
It is done.

gokulgech January 6, 2014 07:59

udf
 
Ansys 14.5>flent 14.5


All times are GMT -4. The time now is 12:28.