CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   grid scale in fluent (http://www.cfd-online.com/Forums/fluent/30426-grid-scale-fluent.html)

lingo October 23, 2002 21:42

grid scale in fluent
 
Hi:

when I import *.msh from gambit to fluent,i find the dimension of my model has changed.At first,I want to make the dimension same as the model created in Pro-engineering through "scale".But the dimension of scaled grids is still different from the real model(though the difference becomes less).And I cann't change the domain extent.Can you help me?thank you!

Laika October 24, 2002 03:48

Re: grid scale in fluent
 
Ther are no dimendions in Gambit, so they cannot change. Gambit exports numbers as they are created. These numbers can be in whatever units.

FLUENT interprets these numbers as if they are in meters. So if your numbers are cm instead of meters, you should devide inside fluent each value by 100 (scale factor 0.01). You can do this automaticly, by stating "grid was made in cm"

Of course you cannot change the model extends by hand: fFluent just gives you the extends of the grid that is currently in the memory.

Example: you create a tube inside Gambit and mesh it. You created it having mm in mind. Let's say the tube is 600mm long, 100mm diameter. When you read in the mesh in FLUENT, FLUENT thinks the tube is 600m long and 100m in diameter. The domain extends are x[0,600]; y[-50,50]; z[-50,50]. So you scale by telling Fluent the grid was created in mm. After scale, the domain extends are x[0, 0.6] ; y[-0.05, 0.05]; z[0.05, 0.05]

If you know your model, the domain extends tell you if the mesh needs to be scaled or not.

If necessary, you can set the scale factors by hand.

greetings,

Laika, still orbiting

An Modh Coinniolach October 24, 2002 06:08

Re: grid scale in fluent
 
The problem could be in Pro-E. Check that your units are set to mm, the default is inches.

lingo October 25, 2002 03:02

Re: grid scale in fluent
 
Lakier:

Did you mean the default unit is inch instead of mm in Pro-e?( I used to think the unit is mm)If so ,how to change the unit to mm?Thanks.

An Modh Coinniolach October 25, 2002 06:58

Re: grid scale in fluent
 
If you want to change your units in Pro/E you can go that by selecting from the Menu Manager, "Set Up" then "Units". That will open the Units Manager.

I think now that this is probably not your problem. If you call inches millimetres in Pro/E and export it to Gambit, then Fluent, Fluent should still see "1 unit" in your model as "1 metre", so as Laika said, when you mean 600mm, fluent reads 600m so you would have to scale your model in Fluent, choosing the "grid was made in mm" option.


All times are GMT -4. The time now is 09:04.