CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

error setting up libudf

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 15, 2003, 05:59
Default error setting up libudf
  #1
andrew_garrard
Guest
 
Posts: n/a
I have recently got a new machine to run fluent 6.1.18 or which is a linux machine rather than the sun that I am used to. I have tried to build my libudf structre and I think that it is all OK, because I got fluent to build it for me. Unfortunaly I am getting errors I don't understand. I made the simplest .c file, so I don't think that is the problem. The error that is produced is below.

Help? anyone, please.

/bin/sh: line 1: cc: command not found

make[3]: *** [test.o] Error 127

make[3]: Target `libudf.so' not remade because of errors.

make[3]: Leaving directory

`/home/mep02ag/cfd/BV_models/libudf/lnx86/2d'

make[2]: *** [lnx86] Error 2

make[2]: Leaving directory

`/home/mep02ag/cfd/BV_models/libudf/lnx86/2d'

make[1]: *** [default] Error 2

make[1]: Leaving directory

`/home/mep02ag/cfd/BV_models/libudf/lnx86/2d'

[mep02ag@dyn056171 libudf]$ ls
  Reply With Quote

Old   August 15, 2003, 11:16
Default Re: error setting up libudf
  #2
pk
Guest
 
Posts: n/a
hi

Makes sure that your machine has a C++ compiler installed on it.

this is necessary for the compilation of the UDFs

Hope this helps you

by

-pk
  Reply With Quote

Old   August 18, 2003, 04:41
Default Re: error setting up libudf
  #3
andrew_garrard
Guest
 
Posts: n/a
Thankyou for your reply, however, I was under the impression that Fluent had it's own C compiler built in specifically for the purpose of building UDF's. When compiling UDF's from source files you can either do it through the Fluent GUI or by typing make "FLUENT_ARCH=lnx86" in the libudf directory.
  Reply With Quote

Old   August 19, 2003, 01:35
Default Re: error setting up libudf
  #4
pk
Guest
 
Posts: n/a
If you plan to use compiled UDFs [ not interpreted udfs] then you will need the C++ compiler. As I had faced similar problem and once I installed VC++ compiler, it works fine [ I am working with windows. ] by
  Reply With Quote

Old   August 19, 2003, 10:17
Default Re: error setting up libudf
  #5
andrew_garrard
Guest
 
Posts: n/a
great, that was the problem, now got a complier and things are working fine. thanks
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
UDF - Error loading libudf Atze Fluent UDF and Scheme Programming 52 May 18, 2015 03:22
load libudf problem alfred Fluent UDF and Scheme Programming 24 November 1, 2013 00:53
Opening library "libudf"... beginner FLUENT 0 August 20, 2007 18:03
no libudf files found after building it pilli4u FLUENT 2 March 22, 2007 16:08
Question about libudf file zhou1 FLUENT 1 January 29, 2004 09:22


All times are GMT -4. The time now is 20:23.