CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

How to run fluent in LINUX

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 31, 2004, 00:38
Default How to run fluent in LINUX
  #1
Selina
Guest
 
Posts: n/a
Hi...

I have recently installed fluent in linux. But I am unable to start it. The error message given is:

"bash: fluent: command not found"

Any help given is greatly appreciated. Thanks

Selina
  Reply With Quote

Old   July 31, 2004, 03:00
Default Re: How to run fluent in LINUX
  #2
sri
Guest
 
Posts: n/a
Try : in the shell window ;

>module load fluent

>fluent

All the best, Sri.
  Reply With Quote

Old   July 31, 2004, 04:45
Default Re: How to run fluent in LINUX
  #3
Rob Hart
Guest
 
Posts: n/a
bash uses an "envirnoment variable" called PATH to tell it where to look for programs.

If you type: echo $PATH it will give you a list of directories (seperated by colons) if the list does not include the directory you installed fluent, then you will need to add it, by typing

PATH=/opt/pkg/Fluent.inc/bin:$PATH

(note this is assuming fluent is installed in /opt/pkg/Fluent.inc/ )

This just works for your current terminal, if you want to make it permenant, you will have to add it to a hidden file called .bashrc

Rob

  Reply With Quote

Old   August 2, 2004, 06:32
Default Re: How to run fluent in LINUX
  #4
Andrew Garrard
Guest
 
Posts: n/a
In the fluent installation guide it says you have to alter the .bash_profile (hidden) file by adding the following lines

PATH=/fluent6/Fluent.Inc/bin:$PATH export PATH

Assuming fluent is installed in dir /fluent6. That works for me and I am running RedHat 9.
  Reply With Quote

Old   August 5, 2004, 07:24
Default Re: How to run fluent in LINUX
  #5
ap
Guest
 
Posts: n/a
On SuSE Linux 9 and 9.1, you have to add the following lines to the hidden file /home/.bashrc

PATH=<path-to-FLUENT.INC-directory>/Fluent.inc/bin:$PATH export PATH

The same settings works for GAMBIT too.

This makes settings permanent for the user the .bashrc file belongs to.

Hi

ap
  Reply With Quote

Old   August 5, 2004, 07:35
Default Re: How to run fluent in LINUX
  #6
Rob Hart
Guest
 
Posts: n/a
BTW, If you want everybody to be able to use fluent, then it's easier to put it in /etc/profile

  Reply With Quote

Old   August 5, 2004, 11:39
Default Re: How to run fluent in LINUX
  #7
ap
Guest
 
Posts: n/a
Yes, but in such a case, it is better to use /etc/profile.local instead of changing /etc/profile because there are chances that the changes to /etc/profile will be lost during system upgrades.

Hi

ap
  Reply With Quote

Old   August 5, 2004, 12:15
Default Re: How to run fluent in LINUX
  #8
Rob Hart
Guest
 
Posts: n/a
Real linux distributions don't overwrite configuration files. Besides, I imagine if your system makes use of a /etc/profile.local, there's probably (or should be) a comment at the top of /etc/profile telling you to go change that instead!

Rob

  Reply With Quote

Old   August 5, 2004, 12:31
Default Re: How to run fluent in LINUX
  #9
ap
Guest
 
Posts: n/a
Yes, there's the comment of course.

My comment is referred to SuSE Linux, which is what I use (and cited in my previous post) and which uses the /etc/profile.local file.

P.S. Real linux distributions? Are there virtual ones? I just know there are usable distributions and unusable ones ;-)

Hi

ap
  Reply With Quote

Old   August 5, 2004, 13:38
Default Re: How to run fluent in LINUX
  #10
Rob Hart
Guest
 
Posts: n/a
lol.

It was just a joke, but maybe quite a cultural one. I know not everybody who reads this is English... sorry

For the record, I use debian.



Rob
  Reply With Quote

Old   August 5, 2004, 14:52
Default Re: How to run fluent in LINUX
  #11
ap
Guest
 
Posts: n/a
:-D

ap
  Reply With Quote

Old   August 5, 2004, 23:01
Default Re: How to run fluent in LINUX
  #12
Selina
Guest
 
Posts: n/a
Hi Rob,Sri,Andrew, ap,

Thanks for all the help and suggestions given. I have managed to get Fluent to work in RHL9. Very grateful.

Seriously, you guys are better at providing technical support than FLUENT.

Thanks again!!!! Selina
  Reply With Quote

Old   January 25, 2011, 16:36
Default
  #13
Member
 
Ivan
Join Date: Aug 2009
Posts: 63
Rep Power: 7
IvanCFD is on a distinguished road
Hi Rob, I reckon you might be of great help to me.

I am newer at using Fluent on Red Hat.

I have just installed it but don't manage to make it work.

Once I have installed it and am in the folder /home/iroldanb/Fluent.Inc/fluent6.3.26/bin I type fluent 3d and nothing worked, it said:

bash: fluent: command not found

Then I did this in that very folder:

$ FLUENT_ARCH=lnx86
$ export FLUENT_ARCH


and when typing again to run fluent I get the same error.

Then I did what Andrew suggests above here, in the folder /home/iroldanb/Fluent.Inc/bin I type

PATH=/home/iroldanb//Fluent.Inc/bin:$PATH export PATH

and back to the executable fluent is, if I type once more fluent 3d the error I get is:

Error: directory /home/iroldanb/Fluent.Inc/fluent6.3.26/fluent[0-9]* does not contain a valid arch.
Set the environment variable FLUENT_ARCH and try again.


I'm sure I'm doing something silly.

Any help?

Thanks a lot beforehand.

Regards,

Ivan.

Last edited by IvanCFD; January 25, 2011 at 16:38. Reason: corrections
IvanCFD is offline   Reply With Quote

Old   June 16, 2011, 06:37
Default
  #14
New Member
 
Tomas
Join Date: Jun 2011
Posts: 3
Rep Power: 6
Tomasete is on a distinguished road
Hello,

I have a similar problem:

[root@server bin]# uname -a
Linux server 2.6.18-164.10.1.el5 #1 SMP Wed Dec 30 18:35:28 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

[root@server bin]# echo $FLUENT_ARCH
lnamd64

[root@server bin]# ./fluent
Error: directory /ansys_inc/v130/fluent/fluent13.0.0/fluent[0-9]* does not contain a valid arch.
Set the environment variable FLUENT_ARCH and try again.


[root@serv fluent13.0.0]# pwd
/ansys_inc/v130/fluent/fluent13.0.0
[root@serv fluent13.0.0]# ls
addons client cpropep ic3m isat launcher lnamd64 packages src vki
bin cortex gtpower info KINetics lib multiport realgas tgrid wave

Any solution? I don't know what to do :-(

Last edited by Tomasete; June 16, 2011 at 07:25.
Tomasete is offline   Reply With Quote

Old   June 20, 2011, 05:32
Default
  #15
Member
 
Ivan
Join Date: Aug 2009
Posts: 63
Rep Power: 7
IvanCFD is on a distinguished road
I am afraid to say I gave up on it.

Much appreciate it if someone comes across with a reliable solution.

Cheers,

Ivan.
IvanCFD is offline   Reply With Quote

Old   June 20, 2011, 07:24
Default
  #16
New Member
 
Tomas
Join Date: Jun 2011
Posts: 3
Rep Power: 6
Tomasete is on a distinguished road
Quote:
Originally Posted by IvanCFD View Post
I am afraid to say I gave up on it.

Much appreciate it if someone comes across with a reliable solution.

Cheers,

Ivan.
Thanks for answering. I've opened a SR in ANSYS Customer Portal. Let's see if they can help me
Tomasete is offline   Reply With Quote

Old   June 21, 2011, 07:48
Default
  #17
New Member
 
Tomas
Join Date: Jun 2011
Posts: 3
Rep Power: 6
Tomasete is on a distinguished road
Solution:

[root@server]# cd /ansys_inc/v130/fluent/bin/
[root@server]# ./fluent


That's the proper route, nor the other

/ansys_inc/v130/fluent/fluent13.0.0

I hope it works for you
Tomasete is offline   Reply With Quote

Old   September 5, 2011, 03:22
Default
  #18
New Member
 
Paola Alpresa Gutiérrez
Join Date: Sep 2011
Posts: 10
Rep Power: 5
Paola is on a distinguished road
Hi IvanCFD,

Did you solve the problem? The last solution given didn't work for me.

Any help would be really appreciated!
Paola is offline   Reply With Quote

Old   September 5, 2011, 09:59
Default
  #19
Senior Member
 
Stuart Buckingham
Join Date: May 2010
Location: United Kingdom
Posts: 267
Rep Power: 16
stuart23 will become famous soon enough
Paola,

You need to first know where you have installed Fluent. If you don't know, open a terminal window and type:
Code:
sudo updatedb
locate fluent
This will give you a bunch of files where fluent is installed. Find the one that looks something like: ....../ansys/13.0/v130/fluent/fluent13.0.0/bin/fluent. The last 2 directories "bin/fluent" will be identical. The rest of it may be different depending on your version.

This file bin/fluent is the launcher. The easiest way to launch is by first nothing the path to "bin/fluent", and then typing in the terminal: (substituting your own path for mine)
Code:
cd /apps/ansys/13.0/v130/fluent/fluent13.0.0/bin
./fluent
Stu
stuart23 is offline   Reply With Quote

Old   September 5, 2011, 10:17
Default
  #20
New Member
 
Paola Alpresa Gutiérrez
Join Date: Sep 2011
Posts: 10
Rep Power: 5
Paola is on a distinguished road
Thank you for the quick answer, stuart, I finally solved the problem!

In case it may help other people:

First, my computer has an architecture: x86_64 (you can see it with "uname -m" command). So I had to set the variable FLUENT_ARCH equal to lnx86, the best thing is to add this line to file .bashrc:
FLUENT_ARCH=lnx86 export FLUENT_ARCH

Second thing was that I have to launch ./fluent from this directory: ../Fluent.Inc/bin/
(instead of this ../Fluent.Inc/fluent6.3.26/bin/). I can also be added to .bashrc:

alias fluent='(personal_path)/Fluent.Inc/bin/fluent'

I'm really glad I found this forum. Best!
Paola is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
parallel fluent setting in linux m2montazari FLUENT 3 October 10, 2011 16:42
FLUENT in Windows Serial and Linux Parallel sham83 FLUENT 0 May 31, 2011 23:38
Dual Boot Windows and Linux and Go Open Source andyj Main CFD Forum 2 October 21, 2010 16:49
Fluent for linux Patryk FLUENT 0 July 20, 2009 19:04
Fluent Remote Simulation Facility Service (RSF) di Rami FLUENT 2 June 4, 2008 05:38


All times are GMT -4. The time now is 17:02.