CFD Online Logo CFD Online URL
Home > Forums > FLUENT

grid generation problem

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   October 27, 2004, 01:26
Default grid generation problem
nabeel mohsin
Posts: n/a
hi, when i import cad file in step format i found problem in grid generation.The error is having small gaps. can tell me how i can handle these error nabeel
  Reply With Quote

Old   October 27, 2004, 08:29
Default Re: grid generation problem
Posts: n/a
It depends on the problem. Is the step file and assembly, and the gaps are small overlaps from the CAD output (usually on the order of 10^-4 or 10^-5)? If this is the case, it's usually best to go back to the original CAD program. In Pro/E we go back and either create a control volume and subtract our parts from it, or we merge the parts together (depending on what we have modeled in Pro/E). These overlaps are then removed by the CAD program and you have a single volume. This might help if you're having problems with a single part as well.

The other common cause is a small gap that is intentional. Let's say you have a missile in a freestream flow with 4 canards (or any other lifting surfaces) sticking out of the missile body and there's a 1/8" gap between the base of the canard and the missile body. Sometimes Gambit will have problems meshing this area. To get around this, split any of these small gaps into their own volumes. For the example I just gave, I would try sweeping the edges of the base of the wing until they intersect the missile body, and then splitting the control volume with these new faces.

If you have any more info on what you're doing, or if you can see where the problem is, just post it and I'll try to help more if I can.

Good luck, Jason
  Reply With Quote

Old   November 4, 2004, 03:58
Default Re: grid generation problem
Posts: n/a
If you have generated your model in Pro/E, go to tools -> options....Uncheck where it says "show only options loaded from file"...Then click on accuracy lower bounds and change it to 1e-06 (0.000001) OK.Then go to edit -> set up -> accuracy and change the accuracy to 0.000001.say "yes" when it asks whether you want it regenerated.While exporting the STEP file export the solids/shells.Hope this helps!!! regards, -Kiran
  Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Elliptic Grid Generation student_58 Main CFD Forum 8 June 9, 2010 02:31
elliptic grid generation prapanj Main CFD Forum 1 November 19, 2007 17:53
???Gambit grid generation...??? Yreadj FLUENT 1 January 30, 2007 19:06
Help Re. Grid Generation Patel Amit R. FLUENT 1 February 28, 2003 22:27
grid generation problem vineet FLUENT 3 April 3, 2002 22:33

All times are GMT -4. The time now is 09:57.