CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Error: Divergence detected in AMG solver? (http://www.cfd-online.com/Forums/fluent/35476-error-divergence-detected-amg-solver.html)

frank January 16, 2005 18:58

Error: Divergence detected in AMG solver?
 
What does mean and how do i fix it? I am runing a rosseland radiation model and it wont run past 1 iteration.

Frank

HASSAN ZOHEIR January 17, 2005 13:41

Re: Error: Divergence detected in AMG solver?
 
you are using the segregated solver, so you must reduce the under relaxation factor as you can.

Tang January 18, 2005 11:48

Re: Error: Divergence detected in AMG solver?
 
You could have a grid issue concerning high skewness. This can be checked by going to contours grid cell equiangle skew and select compute and check the min and max. You should be below .9. If over t5hen this could be your problem. It has happened to me a couple of times.

frank January 19, 2005 20:16

Re: Error: Divergence detected in AMG solver?
 
thanks a million i will try this...

frank

Musa March 4, 2012 00:09

In my case both the min and max skewness value is 1.305729e-10. is it good enough?

a_run_91 June 7, 2012 17:09

Hi all

I am analysing a simple external flow. ANSYS 13.0,pressure based, pressure-velocity coupling:coupled, k-epsilon(realisable,non equilibrium wall function)

Im having the same problem..error message:

"Initialize using the hybrid initialization method.

Checking case topology...
-this case has inlets & outlets both
-pressure information is not available at the boundaries,
so it will be initialized with constant pressure

iter scalar-0

1 1.000000e+00
2 3.467081e+06# Divergence detected in AMG solver: ads-0 -> Increasing relaxation sweeps!

Error: Divergence detected in AMG solver: ads-0
Error Object: #f "

My maximum skewness is 0.84 but orthogonal quantity is too low (10^-12).How can i improve orthogonality??where can we enter TUI commands ??

I tried reducin coupler number, under relaxation factors..etc...but no change in error (except , "Increasing relaxation sweeps!" is not printed in console any more). Even the second itration value remains the same for varied air velocities.

Any of you have any sort of solution to my problems ???? I am desperate to hear thoose.....

everdimension June 7, 2012 17:34

Your orthogonal quality is way too low, this may very much be your problem.
To improve it you should work on your mesh.
First, you should analyse where the bad cells are. To do this, choose 'orthogonal quality' in the 'mesh metric' in mesh statistics in Ansys Meshing. A histogram will appear. You should press 'controls' and in the 'maximum' field enter '0.1', and then 'update y-axis'. That way you leave only the cells of quality less than '0.1' showing in the histogram. Now you can click the bars on the histogram and the bad cells will show on your model.

Minimum recommended orthogonal quality is 0.1, may be even 0.2.

There can be different reasons for having bad orthogonal quality. May be these cells appear on the border of tetra and hexa cells, may be you have a very small inflation thickness but very wide cells. May be something else. Good luck in finding out and getting rid of those cells!

a_run_91 July 21, 2012 13:29

Quote:

Originally Posted by everdimension (Post 365340)
Your orthogonal quality is way too low, this may very much be your problem.
To improve it you should work on your mesh.
First, you should analyse where the bad cells are. To do this, choose 'orthogonal quality' in the 'mesh metric' in mesh statistics in Ansys Meshing. A histogram will appear. You should press 'controls' and in the 'maximum' field enter '0.1', and then 'update y-axis'. That way you leave only the cells of quality less than '0.1' showing in the histogram. Now you can click the bars on the histogram and the bad cells will show on your model.

Minimum recommended orthogonal quality is 0.1, may be even 0.2.

There can be different reasons for having bad orthogonal quality. May be these cells appear on the border of tetra and hexa cells, may be you have a very small inflation thickness but very wide cells. May be something else. Good luck in finding out and getting rid of those cells!

THANKS a lot for your reply everdimension.....


All times are GMT -4. The time now is 05:50.