CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   error parallel fluent session (http://www.cfd-online.com/Forums/fluent/35563-error-parallel-fluent-session.html)

Diet January 26, 2005 11:57

error parallel fluent session
 
hello,

I'm running a parallel computation on a network of four Linux workstations with a single processor each. When I configure the network by spawning the computers in it, it works, but Fluent gives the warning

"DISPLAY environment variable is not set. Graphics and GUI will not oprate correctly without this being set properly."

I neglect this and then I read the case-file (that uses UDF's: UDS and UDM) without any problems, and I can perform the simulation properly. When I interrupt the simulation or, the simulation stops because the given number of time steps is reached, I cannot start the simulation again. It gives the error:

999999 (mpsystem.c@1210): mpt_read: failed: errno = 104

999999: mpt-read: error: read failed trying to read 4 bytes: connection reset by peer

EOF on command stream. The fluent process could not be started.

than I have to exit fluent, because it fails to execute any other command. Saving the data is possible (as well before the error as after it), but when I start another parallel session in a new fluent, and I read case and data, I cannot perform the simulation starting from the previous data, and the same error message appears.

Is this a hardware problem? What should I do?

thanks

Diet

Dave H January 27, 2005 11:28

Re: error parallel fluent session
 
Unfortuneatly it can be hard to tell what this is (at least for me).

But I run a 4 node beowulf and here are some of the probs I ran into and maybe this will help:

file system is not the same on each node ie the file you are reading on the head isn't the same as on the nodes....I use UDF's and this has many times also caused this error...they must also be the same. My fix was to export the head nodes filesystem via NFS and then mount it on each node. That way it is always the same!

rsh protocol not setup correctly? (but it had a different error)

check your firewall setting?

try running in text mode on each node to make sure that fluent is able to run correctly. the move back to the head node and spawn each node individually testing each with running your case file as you go.

in regards to the graphics error, not to worry just relates to exporting the display to the correct addy and isn't necessary as I get it on another cluster I have used and it never resulted in probs.

hope this helps.

DH

Diet January 27, 2005 13:31

Re: error parallel fluent session
 
hi,

thanks for your answer... it seems that the problem has to do with the switch from first order discretisation to a QUICK scheme for my UDS transport equations... strange because a normal second order scheme works correctly.... I'll perform my simulation thus with a second order instead of the QUICK scheme

greetz Diet


All times are GMT -4. The time now is 16:13.