CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Help: axial pump :Iges problem (

nithyanand January 30, 2005 13:06

Help: axial pump :Iges problem
hi I have modeled an axial flow blood pump in Uni graphics.I wanted to do the flow analysis in fluent,so i imported it into GAMBIT thru IGES format. Now that the IGES imports have only surfaces i have to stich the surfaces of pump blades into volumes and subtract this volume from the casing volume to get the flow domain.But this STITCHING is causing the problem ,on given for stiching an error message comes saying the faces are NOT CONNECTED.I am pretty sure in my UG model that the faces are connected and also they seem to be connected in the IGES Import. Can anybody help me in this matter Thank you

Jason January 30, 2005 13:29

Re: Help: axial pump :Iges problem
When it says faces are not connected, what it means is that the faces are not sharing a common edge. What is possibly happening is that there are two edges sharing the exact same space, but are still two separate edges. Sometimes what you can get away with is going to the edges->connect command, and then highlight everything... Gambit should go through and try to match up every pair of edges that can be connected. Sometimes it doesn't work though, and you have to find the specific edges that aren't connected.

Hope this helps, and goodluck Jason

zxaar January 30, 2005 20:41

Re: Help: axial pump :Iges problem
check again if the model is properly exported to iges ..since i have been importing iges quite often and i never saw thi sthat i have to stich the faces to create the solid in gambit again if the model is properly exported gambit will make the solid for you ..

firedragon January 31, 2005 00:43

Re: Help: axial pump :Iges problem
Maybe Stp file format is better than Iges's,because Gambit can eat it better.after importing the Stp file into gambit, you should cleanup the geometry throuth merging the edges and faces.

Mark January 31, 2005 12:04

Re: Help: axial pump :Iges problem
I usually export a parasolid from UG


gelisli February 2, 2005 05:25

Re: Help: axial pump :Iges problem

Your main problem is that distance between the geometric entities is bigger than Gambit ACIS tolerans(1e-6). In order to solve the problem,

1) Try parasolid or step file export in UG and sellect make tolerant option in the Gambit import menu.

2) If this not work delete all the volumes (not their faces) and use heal real face command with stich faces option. This should give you a fully connected volumes. Then you can decompose it using virtual geometry tools. However, using virtual geometry makes it impossible to use boolean operations. So you may need to create the flow volume in a more time consuming way (creating and stiching faces)

3)If this not work, try import the geometry with tolerant modelling option enabled then connect disconnected edges or faces together using virtual tolerance or virtual forced option. Be carefull about the faces or edges that can be connected only if "T Junction" option is enabled in the connect edges or face menus. This is the most time consuming way but it always works.You can use semi-automatic cleanup tool in the tools menu to make the things easier.

In my opinion, the best thing you can do is obtaining the flow volume in UG. UG has many different options that will speed up the geometry build up process. I suggest you to use extract region form to extract the inner faces (faces that will be the boundaries of your flow domain)of your geometry and close the openings or holes. Then sew all the faces to create a solid body and export it as a parasolid file. This probably will solve all of your problems.


All times are GMT -4. The time now is 18:14.