CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Fluent creating wall zone on mesh import? (http://www.cfd-online.com/Forums/fluent/36248-fluent-creating-wall-zone-mesh-import.html)

Mark April 3, 2005 13:54

Fluent creating wall zone on mesh import?
 
I'm doing a 3D analysis of a sail with mast. I've created 4 volumes close around the mast/sail meshed with mapped hexahedra, then a large volume with the 4 smaller ones subtracted from it meshed with with tets. I set the inlet and outlet zones and the sail/mast and bottom of the volume as walls.

When I read the .msh into fluent it creates a zone called 'wall' set to type 'wall' which includes the 4 volumes around the mast/sail needed for the mapped hex mesh. This obviously totally stuffs up the analysis, there doesn't seem to be an appropriate zone type to change it to or way of removing it.

Why does fluent do this? Is there a way round?

Any help much appreciated. -- Mark

daniel April 4, 2005 05:00

Re: Fluent creating wall zone on mesh import?
 
hello

what is written in gambit when you export your mesh. because i think it's your mesh problem and not a gambit one.

ok

cip

Mark April 4, 2005 05:59

Re: Fluent creating wall zone on mesh import?
 
Gambit says:

"A default (unspecified) continuum entity was created" "A default (unspecified) boundry entity was created"

I'm guessing the continuum is the fluid so that is ok but the boundry entity is the problem one. Why does Gambit make one on mesh export?

daniel April 4, 2005 06:24

Re: Fluent creating wall zone on mesh import?
 
because you didn't set it before. try to find it and assign it a boundary condition

Jason April 4, 2005 07:14

Re: Fluent creating wall zone on mesh import?
 
It sounds like your faces aren't connected (that means you have two different faces sharing the same space... one for each volume... what you want is one face shared by both volumes... this way when you export the mesh Gambit will consider the face as part of the fluid and will not write a boundary condition for it). You have to be careful how you build your geometry in Gambit. Here is the order I would recommend:

1) Create or import the geometry for your Mast 2) Create your large volume 3) Subtract the mast from your large volume 4) Create the 4 smaller volumes around your mast 5) SPLIT the large volume with the smaller ones

The split command (making sure you don't turn off the "connected" option) keeps the volumes connected so they share the face where the split occured.

Another option (since you already have the volumes created) is to go back and manually connect the faces. Delete the mesh on the large volume before doing this. Under the face commands, it's the one that looks like the instructions for plugging something into an extension chord. You might be able to do this for all of the faces at once. Odds are that you're going to have to do it one face at a time though. Where ever two volumes are adjacent, make sure there is only one face between them.

The last option is to use the "interface" boundary condition. I don't recommend this, but if you must, you must. Where ever there are two faces that are adjacent, you have to give each face an interface bc. Then in Fluent you define your grid interfaces (define -> grid interfaces). You can group faces, but I would be careful. If you try to define the grid interface in Fluent, and the two BCs you pick don't contain adjacent faces, then you're going to have problems (if Fluent will even let you define the interface).

I think the best option is to manually connect the faces (but that's ONLY because you already have the geomtry built... next time use split commands to avoid this problem).

Hope this helps, and good luck, Jason


All times are GMT -4. The time now is 18:26.