CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Problem for modeling hydrocyclone (http://www.cfd-online.com/Forums/fluent/36441-problem-modeling-hydrocyclone.html)

Nicolas April 20, 2005 10:05

Problem for modeling hydrocyclone
 
Hi everyone, I need to modeling the flow in a hydrocyclone (which use to separate oil of water) and I have some problems. I use RSM with mixture model, second order, unsteady, Presto and Simplec. I saw on this fourm that it work very well.

But not for me. After 80 iterations i have this error : "Error:> (greater than):invalid argument [2]:wrong type (not a number) Error object : nanq" What is it? I have this error after 80 iterations (time step 0.2s, iteration by time step:70). And continuity increases to 1e+3 after error.

Could you help me please?

PS:Sorry for my english.

zxaar April 21, 2005 02:24

Re: Problem for modeling hydrocyclone
 
try smaller time steps like 0.0001, or 5E-05

Nico May 3, 2005 03:36

Re: Problem for modeling hydrocyclone
 
After more investigation the problem was due to the mesh. I had 3 or 4 mesh with the skwenesses>0.9. No it's work, but I have an other question. In first i calculate the flow just for water (inlet oil volume fraction = 0) then i add the oil (inlet volume fraction = 0.5). But, and it's very strange, the oil not leaves the cyclone. So I let my simulation works and after 70sec there is no change. Oil stay in hydrocyclone. Velocity inlet is 20m/s and cyclone is a 75mm diameter. Somebody for help?


All times are GMT -4. The time now is 14:15.