CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Why Fluent does not work on Linux? (http://www.cfd-online.com/Forums/fluent/37117-why-fluent-does-not-work-linux.html)

pzyss July 1, 2005 07:02

Why Fluent does not work on Linux?
 
Hello everyone! I have used Fluent on Windows for two years and now I want to work on linux.

I have installed Fluent6.2.16 on Redhat Linux and set PATH for bin. But when I run fluent, it does not work and prompt out the following line: "Error:directory /CFD/Fluent.Inc/fluent[0-9]* does not contain a valid arch. Set the environment variable FLUENT_ARCH and try again." Would anyone tell me what is the problem and what shall I do?

vengi July 1, 2005 09:59

Re: Why Fluent does not work on Linux?
 
Hai,

Be sure that your Fluent.Inc directory is available in /usr/local/. directory. The license file should be respective license folder. Then try to run /usr/local/Fluen.Inc/bin/(fluent or gambit).

All the best...

pzyss July 1, 2005 11:25

Re: Why Fluent does not work on Linux?
 
Thanks a lot, vengi!

Installing Fluent to a dir other than /usr/local/. will bring the error?

BTW, the edition of Redhat is newest, i.e. Redhat EA 4. And CPU is AMD 64 3000+.


pUl| July 1, 2005 12:18

Re: Why Fluent does not work on Linux?
 
You need to do certaing things after installing.. for starters type this at the bash prompt.

FLUENT_ARCH=lnx86 <Return>

export FLUENT_ARCH <Return>

The fluent user services center has a cool guide that walks you through the installation. Please read it.

pzyss July 1, 2005 21:33

Re: Why Fluent does not work on Linux?
 
Thanks, pUl|

It sounds reasonable. Should I also add these two lines to ~/.bash_profile? Or any where else.

pUl| July 1, 2005 23:42

Re: Why Fluent does not work on Linux?
 
yes, that would make life easier.

pzyss July 2, 2005 09:06

Re: Why Fluent does not work on Linux?
 
But the problem is still there. I am almost mad!

mreg July 2, 2005 09:54

Re: Why Fluent does not work on Linux?
 
you should add the following lines at the end of the /etc/profile file:

PATH=/<where is located>/Fluent.Inc/bin:$PATH export PATH # in case you use mozilla ;-) export FLUENT_HELP_BROWSER=mozilla <empty line>

then reboot, so that the path statement is re-read

mreg July 2, 2005 09:59

Re: Why Fluent does not work on Linux?
 
Sorry, some chars disappeared.

You should add the following lines at the end of the /etc/profile file:

PATH=/(where it is located)/Fluent.Inc/bin:$PATH

export PATH

# in case you use mozilla ;-)

export FLUENT_HELP_BROWSER=mozilla

(empty line at the end)

then reboot, so that the path statement is re-read

pUl| July 2, 2005 15:40

Re: Why Fluent does not work on Linux?
 
No, that might not solve your problem. All it does is add a path definition which will make your life easier by just typing 'fluent' instead of '/usr/local/Fluent.Inc/bin/fluent'

pzyss: To solve your problem, start fluent from the path in which it was installed. If I had to guess, this would be somewhere inside the /CFD directory structure for your case. Try to 'cd' all the way into the 'bin' subdirectory and execute fluent from there using ./fluent

PS: Oh, and by the way mreg, we don't reboot for everything in the *nix world.

pUl| July 2, 2005 15:43

Re: Why Fluent does not work on Linux?
 
Forgot to mention: add the path definitions to your .bash_profile and respawn a shell. There is no need to reboot.

pUl| July 2, 2005 20:43

Re: Why Fluent does not work on Linux?
 
Ok, here goes: An excerpt from the Fluent webpage:

What Linux Platform should I Download?

For the Linux + Pentium there are two download options:

1. Pentium+Linux (RHEL3/SLES9)

2. Pentium+Linux (SLES8)

In general, Pentium + Linux (RHEL3/SLES9) is for RedHat Enterprise3 and SuSe Linux Enterprise Server 9 and later. Pentium + Linux (SLES8) is for earlier versions, notably Red Hat 7 but it depends on your version of glibc.

To check which version you have with:

rpm -qa | grep glibc

if you get: glibc-2.3*************** download the RHEL3/SLES9 package

if you get glibc-2.2************** download the SLES8 package.

If you install ONLY lnx86_glibc22 version then fluent won't run and you will get the following error message:

Error: directory /.../Fluent.Inc/fluent[0-9]* does not contain a valid arch. Set the environment variable FLUENT_ARCH and try again.

This is because the part of bin/fluent script that checks for a valid arch happens before the rpm check for the glibc version and thus the arch is still "lnx86" at this point.

Resolution:

You can fix this by installing the RHEL3/SLES9 package in addition to the SLES8 package. (It does not matter which package you install first). Installing both packages also means that FLUENT will continue to work when you upgrade your operating system.

HTH

-pUl|

pzyss July 2, 2005 20:43

Re: Why Fluent does not work on Linux?
 
Yes, of cause I have cd into the bin dir and type fluent. But it do not work. :(

pzyss July 2, 2005 21:22

Re: Why Fluent does not work on Linux?
 
Thank you so much! -pUl|

I have check the version. The OS is RHEL4. However CPU is AMD ALTHLON 3000+. glibc version is 2.3. Fluent version is 64BIT 6.2.16.

You meanse I should download RHEL3/SLES9 package? RHEL3/SLES9 is just a package or a Linux version? I am wondering.


pzyss July 3, 2005 02:51

Re: Why Fluent does not work on Linux?
 
I have added the following two line in profile. The above problem has been solved.

FLUENT_ARCH=lnamd64 export FLUENT_ARCH

However, another error came out:

Warning: DISPLAY environment variable is not set. Graphics and GUI will not operate correctly without this being set properly. ......cortex.3.6.6:cannot execute binary file.

What is the problem come from and how to fix it?

pzyss July 3, 2005 04:05

Re: Why Fluent does not work on Linux?
 
Hi~~pUl|

The problem now reduced to : when I run fluent, the following lines come out: /CFD/Fluent.Inc/fluent6.2.16/cortex/lnamd64/cortex.3.6.6 -f fluent (fluent " -alnamd64 -path/CFD/Fluent.Inc") /CFD/Fluent.Inc/bin/fluent: line 3702: /CFD/Fluent.Inc/fluent6.2.16/cortex/lnamd64/cortex.3.6.6:cannot execute binary file.

What is the problem? Herhaps This is the last problem to be solved!

pUl| July 3, 2005 14:48

Re: Why Fluent does not work on Linux?
 
Are you really on a 64 bit architecture?

pzyss July 3, 2005 20:26

Re: Why Fluent does not work on Linux?
 
Yes! pUl| The CPU of my computer is AMD 64Bit Athlon 3000+. Are all version of Fluent higher than 6.2 on linux 64Bit? I think the problem is that the version of Fluent is sensitive of OS and Achitecture. For me I should use SuSU linux, not Redhat. I will have a try!

calvin March 9, 2011 12:35

hey pzyss
m facing similar problem ..
did u get thru it n how
pl help

kumawatnana February 2, 2013 03:38

Setting environment variable for fluent arch in ubuntu 11.04
 
Hii
can anyone help me for Setting environment variable for fluent arch in ubuntu 11.04. i have installed fluent 6.3 (home/username/Fluent_lnc) in ubuntu 11.04 but when i start fluent i get error set fluent arch.

please help...
...kumavat


All times are GMT -4. The time now is 13:43.