CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   periodic boundaries (http://www.cfd-online.com/Forums/fluent/37961-periodic-boundaries.html)

Mary September 21, 2005 03:52

periodic boundaries
 
I want to define two rotational periodic boundaries (the angle between them is 180). They are identically (equal number of faces, equal geometry).

/grid/modify-zones> make-periodic Periodic zone [()] 5 Shadow zone [()] 7 Rotational periodic? (if no, translational) [yes] yes Create periodic zones? [yes] yes

zone 5: matched 13596 out of 15234 faces. zone 7: matched 13596 out of 15234 faces.

Error: Failed to make zones periodic. Error Object: #f

Can someone help me ??

KHAN September 26, 2005 13:13

Re: periodic boundaries
 
can u specify the details of the geometry, then we can discuss about the problem - thanks!


m5edr February 25, 2012 07:18

Re
 
I'm now face the same problem
could any one pls, tell me how to fix this problem

dbarnett March 16, 2012 13:29

Re: periodic boundaries
 
Has anyone determined a solution to this problem in Fluent? I also am working on simulations that require rotational periodicy. Occasionally I am able to create the periodic zones, but sometimes I receive the errors: "Error: Failed to make zones periodic. Error Object: #f"

I believe that I am not doing anything different when I create the periodic zone successfully. I am always ensuring that the rotational axis is aligned with the z-axis of the geometry and I am using match control in meshing for the two faces of the periodic zone. Any ideas of what may casue this?

m5edr March 16, 2012 22:20

Quote:

Originally Posted by dbarnett (Post 349888)
Has anyone determined a solution to this problem in Fluent? I also am working on simulations that require rotational periodicy. Occasionally I am able to create the periodic zones, but sometimes I receive the errors: "Error: Failed to make zones periodic. Error Object: #f"

I believe that I am not doing anything different when I create the periodic zone successfully. I am always ensuring that the rotational axis is aligned with the z-axis of the geometry and I am using match control in meshing for the two faces of the periodic zone. Any ideas of what may casue this?

yes i solved it before,
Type in Fluent command Window
>Mesh
>mp if doesn't work try to type the following and change number
>Mesh
>Mz
>Mt "change value (limit is 0.5)"

evswbok March 17, 2012 22:39

i faced the same problem. maybe u shoud make periodic in your meshing software ,then export the grid,at last import into FLUENT、、、、、、、which meshing software you are useing??ICEM CFD can do it.

Chavagnatze December 14, 2012 04:46

*I know I am late but, you must have the axis of rotation in the global z-direction for rotational periodicity. It may also be true that translational periodicity must be orthogonal across z as well.

Use /mesh/rotate in the interpreter and set your point of origin and axis of mesh rotation so that the global z-axis is parallel with the axis of periodicity

use /mesh/mz/make-periodic in the interpreter and move on as usual. You can also invoke periodicity in your meshing software (* Z-axis and axis of periodicity must be parallel) and Fluent should take care of it from there.

If there is a way to make the stored axis something other than (0 0 1) or any other vector, none of the above would matter.

AbolfazlJalalabadi May 12, 2013 08:16

Quote:

Originally Posted by Mary
;124397
I want to define two rotational periodic boundaries (the angle between them is 180). They are identically (equal number of faces, equal geometry).

/grid/modify-zones> make-periodic Periodic zone [()] 5 Shadow zone [()] 7 Rotational periodic? (if no, translational) [yes] yes Create periodic zones? [yes] yes

zone 5: matched 13596 out of 15234 faces. zone 7: matched 13596 out of 15234 faces.

Error: Failed to make zones periodic. Error Object: #f

Can someone help me ??

Hi
The default tolerance can be problematic in small meshes

just use the text command
grid/modify-zone/mt
and specify smaller tol's untill all nodes are matched up and then you're good to go
I had to reduce from 0.1 to 1e-6

robboflea October 23, 2013 02:52

I was facing the same problem and I solved it by changing the rotation axis on the "cell zone condition" tab. My geometry was rotationally periodic along x axis but standard fluent settings use the z axis as the rotation axis.

I hope this helps!

Cheers,

Rob

Vidyanand Kesti October 23, 2013 05:58

This is problem of mesh, if you not mesh same cell size and division on periodic boundaries, Fluent through this error, If you want to avoid

1.Remesh,with match control.

2.If it irregular geometry then use periodic interface in fluent ( interface option defining boundaries as interface )

wdxgd January 9, 2014 23:09

wdxgd
 
Quote:

Originally Posted by robboflea (Post 458433)
I was facing the same problem and I solved it by changing the rotation axis on the "cell zone condition" tab. My geometry was rotationally periodic along x axis but standard fluent settings use the z axis as the rotation axis.

I hope this helps!

Cheers,

Rob

It is useful,thanks:)


All times are GMT -4. The time now is 04:36.