CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Error when loading a shared library

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 27, 2006, 17:04
Default Error when loading a shared library
  #1
rid
Guest
 
Posts: n/a
Hi I got some problems loading a parallel udf. When I try to compile the udf, averything works well, but , when I load it I got this error therfore i can't open my old file case and dat

*********************

oapening library "libudf"... Primitive Error at Node 1: open_udf_library: No such file or directory

Library "libudf/lnx86/3ddp_host/libudf.so" opened

inlet_x_velocity

***************** thank you for your help
  Reply With Quote

Old   May 27, 2006, 19:39
Default Re: Error when loading a shared library
  #2
Peter
Guest
 
Posts: n/a
If you used a fluent parallel session such as 'fluent 3ddp -t2' to build your UDF before (when you used the old case and dat files), then you will also need to start a parallel session now, before reading your case and data files.
  Reply With Quote

Old   May 29, 2006, 11:57
Default Re: Error when loading a shared library
  #3
rid
Guest
 
Posts: n/a
Hi, i used a fluent parallel session fluent 3ddp, i build my udf before reading my case and data files.the Udf is build with success. but when i read case and data file tje same error appears:

Opening library "libudf"... Primitive Error at Node 0: open_udf_library: No such file or directory

Library "libudf/lnx86/3ddp_host/libudf.so" opened please help me
  Reply With Quote

Old   May 29, 2006, 13:47
Default Re: Error when loading a shared library
  #4
Mac
Guest
 
Posts: n/a
Are the two machines of the same architecture (i.e. both are 32 bit or 64 bit)?
  Reply With Quote

Old   May 29, 2006, 14:51
Default Re: Error when loading a shared library
  #5
rid
Guest
 
Posts: n/a
i used a machine with 32 bits

  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem loading UDF library in parallel cluster Veera Gutti FLUENT 7 July 3, 2011 09:15
DecomposePar unequal number of shared faces maka OpenFOAM Pre-Processing 6 August 12, 2010 09:01
BEGINNER: error while loading shared libraries ka1184 OpenFOAM 3 February 19, 2010 08:11
error while loading shared libraries: libelf.so.0: cannot open shared object file: No esmailpour OpenFOAM 7 October 15, 2009 07:09
OpenFOAM141dev linking error on IBM AIX 52 matthias OpenFOAM Installation 24 April 28, 2008 15:49


All times are GMT -4. The time now is 06:58.