CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Help setting up Fluent for a rotor blade (http://www.cfd-online.com/Forums/fluent/41549-help-setting-up-fluent-rotor-blade.html)

Fluent learner June 28, 2006 09:13

Help setting up Fluent for a rotor blade
 
Hi all,

I am quite new to using Fluent. Have done some successfull simulations with stationary reference frame before. Now I am trying to model a helicopter rotor blade in hover. I have made several unsuccessful attempts with the help of the online manual. The results do not show the expected flow field. Can one of you wizards help me with setting it up correctly?

a) I am defining it as unsteady, coupled implicit solver with the Spalart Allmaras turbulence model. I have a wall boundary condition for the blades. I am keeping the blades in the rotating reference frame and set the rotational speed in radians per second in the absolute frame. I also have a pressure far field boundary condition for far stream conditions. Since it is hover I keep a zero Mach number for the pressure far field.

b) I have also tried to simulate the problem in another way - by keeping the blade stationary and making the fluid rotate. For this I used a rotating frame in the fluid zone and kept the wall stationary. The pressure far field boundary conditions are the same as in case (a).

Both these aproaches do not give the correct flow field. Also when I export the solution to a FieldView file format, the flow field is in the inertial reference frame. Is there a way to convert it to a rotating reference frame solution so that I can view the stream lines correctly? I am using an unstructured grid for the simulations.

Could you tell me how to set Fluent for this rotating blade in both the reference frames - rotating reference frame and inertial reference frame. I would be very grateful to fast replies, have a deadline for this in less than a week!!! Thanks!

Regards, NY.


Dan July 5, 2006 07:53

Re: Help setting up Fluent for a rotor blade
 
Have you tried sliding mesh?

Fluent learner July 11, 2006 10:56

Re: Help setting up Fluent for a rotor blade
 
Yes, I have tried the sliding mesh, but it asks for an interface. There is no interface in my case between the helicopter blades. The case is just - 2 rotor blades in air and they are rotating at a constant angular velocity about the y axis. Can you tell me how I should set up the boundary conditions step by step? Thanks in advance.

NY

Jason July 11, 2006 12:01

Re: Help setting up Fluent for a rotor blade
 
It's not asking for an interface between the blades, it's asking for the interface between the rotating volume and the stationary volume. The sliding mesh requires two separate volumes (you would typically split a a squat cylinder around your blades from the main geometry). In this case, you would want the connected option turned off when splitting the volume. Now you have two separate volumes, and you define the faces where the two volumes touch as interfaces.

Hope this helps, and good luck, Jason


All times are GMT -4. The time now is 13:34.