CFD Online URL
[Sponsors]
Home > Forums > FLUENT

OpenGL problem in Fluent for Linux

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 16, 2007, 02:34
Default OpenGL problem in Fluent for Linux
  #1
Jack
Guest
 
Posts: n/a
Hi! Everyone, I am running Fluent in Redhat enterprise linux 4. I have no problem running gambit and fluent, but whenever it is neccessary to bring out a graphical windows, an error message reads: Error message from graphics function Show_Device_Info: The OpenGL driver was requested but is not available in this Hoops. Does that mean I have no OpenGL driver installed? If that's the reason, could anyone please tell me where to download the correct Open GL driver? my display card is ATI X300. Thanks a lot
  Reply With Quote

Old   January 16, 2007, 13:38
Default Re: OpenGL problem in Fluent for Linux
  #2
Seeker Phil
Guest
 
Posts: n/a
Hi Jack, I guess you are connecting to a server and running Fluent on another machine. If this is so, you will need to set your GLX extensions correctly.

Phil
  Reply With Quote

Old   January 16, 2007, 20:18
Default Re: OpenGL problem in Fluent for Linux
  #3
Jack
Guest
 
Posts: n/a
Hi! Phil, No, I am not running Fluent on a remote machine but I have problems on that too. Both Fluent and Gambit sends error messages without starting anything. I already change the ssh_config but for some reason it still not running. Now, back to my local machine problem, it looks like Linux cannot find an OpenGL driver but I think that should come with any version of Linux distribution. I think RedHat accidentally remove something when fixing bugs for this new release. I didnt have that problem with earlier release of RedHat Enterprise 4 (Yes they are both RHEL4 but just different minor releases)
  Reply With Quote

Old   January 17, 2007, 13:45
Default Re: OpenGL problem in Fluent for Linux
  #4
Seeker Phil
Guest
 
Posts: n/a
Hi Jack, Unfortunately, I do not know what the problem might be. You can try to manually install and configure the OpenGL drivers and GLX extensions as well and see if it works. In case you have not seen this already, heres a link to the software:

http://www.sgi.com/products/software/

Hope this helps, Binoy

  Reply With Quote

Old   January 23, 2007, 07:32
Default Re: OpenGL problem in Fluent for Linux
  #5
Robert Flint
Guest
 
Posts: n/a
I am having the same problem on SUSE 10.2. Gambit works fine but when I use the display option in Fluent 6.3 I get the same error message as Jack. I am using an Nvidia Quadro card with the Nvidia driver installed.

Any advice would be appreciated.

ROB

  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
fluent parallel problem in win7 x64 system dunga82 FLUENT 8 April 19, 2012 21:23
fluent convergence problem josip76 FLUENT 0 May 26, 2011 21:08
Fluent boundary conditions problem bobo FLUENT 2 July 3, 2009 07:28
Fluent parallel license problem brothershuai Main CFD Forum 0 July 1, 2009 16:41
Fluent problem Z FLUENT 1 April 8, 2005 05:22


All times are GMT -4. The time now is 22:30.