CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Linking two meshes (http://www.cfd-online.com/Forums/fluent/44310-linking-two-meshes.html)

Geoffroy Chaussonnet March 30, 2007 15:01

Linking two meshes
 
Hello,

I want to mesh a streamlined body with Gambit, and i've been advised to use a structural "O-grid". In order to achieve that, i want to link two mesh with diferrent cell size on one surface. This can be asked this way "how to create a surface on which 2 different meshes exist, one is connected to coarse volume mesh (top part) and the other is linked to a fine volume mesh (bottom part).

|-----------------|

|coarse mesh

|-----------------| <- This face MUST links 2 different size meshes

|fine mesh

|-----------------|

Thank you in advance !!

Geoffroy

HSeldon March 30, 2007 21:05

Re: Linking two meshes
 
Hi, In order to do that, you have to use non-conformal mesh. Supposse that you have created 2 volumes and extracted one from another. When you do this, you have to check the "remain" option in the boolean command in Gambit. That will give you the same face twice. Then, you have to set´em as interface in Gambit and then create that interface in Fluent. Go for the sliding mesh theory in Fluent´s docs, there you´ll see the concept I wrote more clearly than my english :)

Hope this helps you!

Geoffroy Chaussonnet March 31, 2007 13:00

Re: Linking two meshes
 
Thank you for you answer !

I have already tried to define the boundary as an interface with Gambit, and then couple the 2 different interfaces with the "Grid interface" menu in Fluent. But it does not work 'cause when you couple the 2 interaces, fluent create a WALL. And i want some fluid getting THROUGH the interface, as if both volumes was only one fluid volume.

So, the problem is for me still unsolved... :(

Geoffroy Chaussonnet April 6, 2007 04:59

Re: Linking two meshes
 
Okay, I just had to read the Fluent User Guide... :P My mistake was to check the "coupled" box in the "grid interface" window. The coupled option has to be used in case of Solid/Fluid interface...


All times are GMT -4. The time now is 07:26.