CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Bugg in Remeshing in 3D - Any Fluent Wizards ?? (http://www.cfd-online.com/Forums/fluent/46344-bugg-remeshing-3d-any-fluent-wizards.html)

Amr October 16, 2007 07:35

Bugg in Remeshing in 3D - Any Fluent Wizards ??
 
Hi all,

I am simulating an oscillating cylinder in cross flow and wish to accomplish this in 3D. There is a linear simple prescribed motion in order to test the model; the motion is currently only in the horizontal direction. By using a simple compiled UDF, enabling smooting and remeshing, everything goes fine in a 2D simulation.

However, when I switch to 3D, the body moves and the cells adjacent to the body keep on getting stretched (smoothed) without remeshing at all. Even after checking and verifying face remeshing and size function, the remeshing doesn't happen for some unknown reason. It appears to me that either I need to add something or modify the settings I used in 2D or that there might be a bug in the 6.3 fluent version. Surprisingly, the 3D cylinder-piston tutorial has its remeshing working fine, but I have also checked this against my case and I couldn't figure out why I have this remeshing inoperable.

Wonder if somebody out there has had a similar obstacle!!!

Awaiting to hear from anybody.

Amr

snailstb November 1, 2011 05:04

Quote:

Originally Posted by Amr
;146244
Hi all,

I am simulating an oscillating cylinder in cross flow and wish to accomplish this in 3D. There is a linear simple prescribed motion in order to test the model; the motion is currently only in the horizontal direction. By using a simple compiled UDF, enabling smooting and remeshing, everything goes fine in a 2D simulation.

However, when I switch to 3D, the body moves and the cells adjacent to the body keep on getting stretched (smoothed) without remeshing at all. Even after checking and verifying face remeshing and size function, the remeshing doesn't happen for some unknown reason. It appears to me that either I need to add something or modify the settings I used in 2D or that there might be a bug in the 6.3 fluent version. Surprisingly, the 3D cylinder-piston tutorial has its remeshing working fine, but I have also checked this against my case and I couldn't figure out why I have this remeshing inoperable.

Wonder if somebody out there has had a similar obstacle!!!

Awaiting to hear from anybody.

Amr

have you solved this problem? I also face this problem for 3D model. LINUX VERSION of FLUENT6.3 is used. 2D is ok for remeshing. Can you give me some advise, thank you very much.


All times are GMT -4. The time now is 13:51.