CFD Online Logo CFD Online URL
Home > Forums > FLUENT

Fluent error "No face with given nodes"

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   December 6, 2008, 02:57
Default Fluent error "No face with given nodes"
Posts: n/a
Hi all,

I have generated a mesh for a General Aviation airfoil in ICEM CFD Hexa,but while solving when I load the mesh in Fluent I get the error message:: " Building...

grid,WARNING: no face with given nodes. Thread 11, cell 1 Error: Build_Grid: grid error.

Clearing partially read grid.

shell conduction zones, Done. "

Can anybody help me in identifying the problem.
  Reply With Quote

Old   August 30, 2011, 12:15
New Member
Join Date: Nov 2010
Posts: 23
Rep Power: 7
VT_Bromley is on a distinguished road
Did you ever find a solution to this problem? Or does anyone know what causes this issue? I'm having the same problem when trying to read my mesh into FLUENT.
VT_Bromley is offline   Reply With Quote

Old   January 16, 2012, 10:11
New Member
Join Date: Mar 2009
Posts: 11
Rep Power: 9
cactilio86 is on a distinguished road
Even if it comes too late for you guys, it might help somebody else in the future.

When this error is displayed, the location of the cell centre where the error occurs is shown. You can get back to your mesher and figure out where that is and try to remesh it. In my case, no inverted volume was reported but the zone, even if fully made of hex's, was complex enough to cause the error.

So I suggest : locate where the error occurs, and remesh that particular volume trying to simplify (or coarsen) the mesh around the point of conflict.

good luck
cactilio86 is offline   Reply With Quote

Old   February 11, 2012, 16:33
Senior Member
Join Date: Sep 2010
Posts: 158
Rep Power: 8
lordvon is on a distinguished road
I kept getting this error on a 2d c-grid airfoil with 5 domains (2 in front of airfoil, 2 behind, and 1 for the blunt trailing edge). But then I merged all of the domains except for the blunt trailing edge domain (now total of 2 domains instead of 5) and it imported perfectly into Fluent. I was using Pointwise.
lordvon is offline   Reply With Quote

Old   January 27, 2014, 12:57
New Member
Join Date: Jan 2014
Posts: 2
Rep Power: 0
4Dboy is on a distinguished road
I realize this is probably too late, but I stumbled across this thread having encountered the same problem, and thought it worth posting in case anyone should do the same. In the end I managed to solve it by running a block "check/fix" and "fix inverted blocks" from the block checks menu: blocking -> block checks -> run check/fix

to be honest, I'm not sure which of these did the job, but after this, the mesh imported fine. Hope that helps.
4Dboy is offline   Reply With Quote

Old   April 21, 2015, 08:57
New Member
zheng Fang
Join Date: Dec 2014
Posts: 3
Rep Power: 3
jianzheng is on a distinguished road
I solved it by "blocking->block checks->Fix inverted blocks".Expecting this can help someone else.
jianzheng is offline   Reply With Quote

Old   June 2, 2015, 11:53
New Member
Join Date: Jul 2014
Posts: 9
Rep Power: 4
RajG is on a distinguished road
i Used Run Check/Fix Block,Inverted Block option showing same error again.

sometimes gives error file has wrong dimension.
[Allready selected 2D in ICEM(whilen converting .uns to .msh) & Fluent(in begining)].

Plse help me anyone to solve this issue.
I am doing just 2D Pipe Flow Analyis of pressure drop.
RajG is offline   Reply With Quote

Old   July 20, 2015, 05:04
Join Date: Mar 2011
Posts: 50
Rep Power: 7
didiean is on a distinguished road
For those who may meet the problem, I would like to share my experience.
I have just met this problem. Checking the orient, I found that one of the blocks was left-handed. After I repaired this, the problem disappeared.
didiean is offline   Reply With Quote

Old   March 27, 2016, 11:34
Default update
New Member
Join Date: Jan 2014
Posts: 2
Rep Power: 0
4Dboy is on a distinguished road
Just as a note. I re-stumbled upon this thread after encountering the same problem again (!) and figured I should write an update in case anyone found it useful.

The error comes about, as far as I can tell, because at least some of the faces defined in your mesh have the incorrect or inconsistent orientation.

I was recently trying to collapse a 3d mesh into a 2d one and this involved messing with the mesh file directly, so i started to get to grips with all the notations and what caused the errors...

in the .msh file, the faces are specified as a list thus: [here we assume a hex-mesh]

(13(Zone first-index last-index type element type)
N1 N2 N3 N4 V1 V2

where here we have 4 nodes (a 3D face of a cell). In 3D the node indexes N1-N4 are specified in a counter-clockwise order. In 2D there would simply be two nodes N1 N2 (say) which specify an edge.

The V1 and V2 values specify the neighboring cells (volumes in 3D, areas in 2D) the orientation MUST be consistent. such that the arrow drawn between V1 and V2 is the right-hand normal of the face. That's a bit confusing, so imagine it in 2D. If we have 2 square cells, and we define the "face" that divides the left (cell 1) from the right (cell 2). This face lies between node number 2 and 5:

4 5 6
! 1 ! 2 !
1 2 3

If we specify the face as:
2 5 then the volume reference MUST be 2 1 (right hand rule)
alternatively, if the face is specified as 5 2 then the cell reference would be the other way around: 1 2

so for this simple example the face specification should be something like:

(13(1 1 7 1 2)(
1 4 1 0 <the zero here is because there is no cell the other side of the edge>
2 5 2 1
3 6 0 2
1 2 0 1
2 3 0 2
4 5 1 0
5 6 2 0

I think the mesh will actually also read in fine if all your directions are backwards, but you will get negative volumes or a left-handed cell warning when you check your mesh. the Fluent TUI command can be used to reverse these directions, or if its easy, you can just swap over the cell references in your faces list in the mesh.

there is a really good guide on the content of the fluent mesh file here which I used, and I would recommend checking this if you are editing your own mesh for fear that I have made some typos etc.

the fluent meshing guide is here:

or google for "fluent meshing users guide" if that doesn't work. There are good examples in Appendix B.

Happy Meshing!!
4Dboy is offline   Reply With Quote

Old   September 6, 2016, 06:17
Join Date: Nov 2011
Posts: 82
Rep Power: 6
robboflea is on a distinguished road
I had the same problem but in my case it was not caused by problems in the grid elements/blocks. It was "only" due to the fact that I was generating a purely 2D grid for fluent on the Z-Y plane. Fluent seem to work only with X-Y planar coordinates. Rotating the grid solved the issue.

Hope it can be of help to anyone
robboflea is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
hanging nodes in fluent; Zafer Zeren FLUENT 6 April 9, 2013 14:25
error: no periodic nodes on thread __. HELP !!! bne FLUENT 0 June 20, 2007 11:57
Mismatch nodes on periodic face>tolerance chotet CFX 2 January 19, 2007 09:37
Looping over nodes of a cell (UDF) error Manoj FLUENT 2 December 1, 2005 01:30
UDF: Nodes associated with a face? Anders Jönson FLUENT 0 June 5, 2003 02:48

All times are GMT -4. The time now is 03:43.