CFD Online Logo CFD Online URL
Home > Forums > FLUENT

Fluent error "No face with given nodes"

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   December 6, 2008, 02:57
Default Fluent error "No face with given nodes"
Posts: n/a
Hi all,

I have generated a mesh for a General Aviation airfoil in ICEM CFD Hexa,but while solving when I load the mesh in Fluent I get the error message:: " Building...

grid,WARNING: no face with given nodes. Thread 11, cell 1 Error: Build_Grid: grid error.

Clearing partially read grid.

shell conduction zones, Done. "

Can anybody help me in identifying the problem.
  Reply With Quote

Old   August 30, 2011, 12:15
New Member
Join Date: Nov 2010
Posts: 23
Rep Power: 6
VT_Bromley is on a distinguished road
Did you ever find a solution to this problem? Or does anyone know what causes this issue? I'm having the same problem when trying to read my mesh into FLUENT.
VT_Bromley is offline   Reply With Quote

Old   January 16, 2012, 10:11
New Member
Join Date: Mar 2009
Posts: 11
Rep Power: 8
cactilio86 is on a distinguished road
Even if it comes too late for you guys, it might help somebody else in the future.

When this error is displayed, the location of the cell centre where the error occurs is shown. You can get back to your mesher and figure out where that is and try to remesh it. In my case, no inverted volume was reported but the zone, even if fully made of hex's, was complex enough to cause the error.

So I suggest : locate where the error occurs, and remesh that particular volume trying to simplify (or coarsen) the mesh around the point of conflict.

good luck
cactilio86 is offline   Reply With Quote

Old   February 11, 2012, 16:33
Senior Member
Join Date: Sep 2010
Posts: 155
Rep Power: 7
lordvon is on a distinguished road
I kept getting this error on a 2d c-grid airfoil with 5 domains (2 in front of airfoil, 2 behind, and 1 for the blunt trailing edge). But then I merged all of the domains except for the blunt trailing edge domain (now total of 2 domains instead of 5) and it imported perfectly into Fluent. I was using Pointwise.
lordvon is offline   Reply With Quote

Old   January 27, 2014, 12:57
New Member
Join Date: Jan 2014
Posts: 1
Rep Power: 0
4Dboy is on a distinguished road
I realize this is probably too late, but I stumbled across this thread having encountered the same problem, and thought it worth posting in case anyone should do the same. In the end I managed to solve it by running a block "check/fix" and "fix inverted blocks" from the block checks menu: blocking -> block checks -> run check/fix

to be honest, I'm not sure which of these did the job, but after this, the mesh imported fine. Hope that helps.
4Dboy is offline   Reply With Quote

Old   April 21, 2015, 08:57
New Member
zheng Fang
Join Date: Dec 2014
Posts: 3
Rep Power: 2
jianzheng is on a distinguished road
I solved it by "blocking->block checks->Fix inverted blocks".Expecting this can help someone else.
jianzheng is offline   Reply With Quote

Old   June 2, 2015, 11:53
New Member
Join Date: Jul 2014
Posts: 9
Rep Power: 3
RajG is on a distinguished road
i Used Run Check/Fix Block,Inverted Block option showing same error again.

sometimes gives error file has wrong dimension.
[Allready selected 2D in ICEM(whilen converting .uns to .msh) & Fluent(in begining)].

Plse help me anyone to solve this issue.
I am doing just 2D Pipe Flow Analyis of pressure drop.
RajG is offline   Reply With Quote

Old   July 20, 2015, 05:04
Join Date: Mar 2011
Posts: 50
Rep Power: 6
didiean is on a distinguished road
For those who may meet the problem, I would like to share my experience.
I have just met this problem. Checking the orient, I found that one of the blocks was left-handed. After I repaired this, the problem disappeared.
didiean is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
hanging nodes in fluent; Zafer Zeren FLUENT 6 April 9, 2013 14:25
error: no periodic nodes on thread __. HELP !!! bne FLUENT 0 June 20, 2007 11:57
Mismatch nodes on periodic face>tolerance chotet CFX 2 January 19, 2007 09:37
Looping over nodes of a cell (UDF) error Manoj FLUENT 2 December 1, 2005 01:30
UDF: Nodes associated with a face? Anders Jönson FLUENT 0 June 5, 2003 02:48

All times are GMT -4. The time now is 08:32.