CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   FLUENT (http://www.cfd-online.com/Forums/fluent/)
-   -   Problem running Fluent on amd64 (http://www.cfd-online.com/Forums/fluent/50474-problem-running-fluent-amd64.html)

Manfred February 4, 2009 07:51

Problem running Fluent on amd64
 
Hi, I've got a problem running Fluent on Ubuntu 8.10 x64. When I start the program I receive the following message error /bin/fluent -r6.3.26 /bin/fluent: 4677: domainname: not found /cortex/lnamd64/cortex.3.7.3 -f fluent (fluent " -r6.3.26 -path/home/manf/Fluent/Fluent.Inc") /cortex/lnamd64/cortex.3.7.3: error while loading shared libraries: libstdc++.so.5: wrong ELF class: ELFCLASS32

I am a newby in the Linux world, so I don't know what to do, please help.

Manfred February 5, 2009 07:00

Re: Problem running Fluent on amd64
 
This is the correct form of the message

/bin/fluent -r6.3.26 /bin/fluent: 4677: domainname: not found

/cortex/lnamd64/cortex.3.7.3 -f fluent (fluent " -r6.3.26 -path/home/manf/Fluent/Fluent.Inc")

/cortex/lnamd64/cortex.3.7.3: error while loading shared libraries: libstdc++.so.5: wrong ELF class: ELFCLASS32

I've omitted the path of Fluent Folder in order to simplify the post

Martin Skov Skjøth-Rasmussen February 8, 2009 16:14

Re: Problem running Fluent on amd64
 
I have Fluent running on Ubuntu X_64, and experienced the same problems. What you need to do is to install all missing libraries:libstdc++.so.5 for one... In a terminal window: sudo apt-get install libstdc++5 sudo aptitude install libmotif3 sudo aptitude install libxaw7 /Martin

Manfred February 14, 2009 07:01

Re: Problem running Fluent on amd64
 
Thank you Martin, seems to work

Mir5 April 20, 2009 03:59

problem ruunig fluent on ubuntu 8.1 (64 bit)
 
I have problem in installing fluent 6.3 on ubuntu 8.1
I have installed the fluent software and then installed following packages:
sudo apt-get install libstdc++5
sudo aptitude install libmotif3
sudo aptitude install libxaw7 /Martin

So i run the fluent in 2d or 3d version
But i have the following error :


/Fluent.Inc/license/lnamd64/fluentlm-helper91: no such file

No error handler available
....


Anybody Can Help?

RPereira July 31, 2009 08:29

I've the same problem as Mir5 for FLUENT...

And for Gambit I've this error:

LANG en_US.UTF-8 changed temporarily to en_US for gambit use.
Starting /Fluent.Inc/gambit2.4.6/lnamd64/gambit ...
*** can't exec /Fluent.Inc/license/lnamd64/fluentlm-helper90: No such file or directory
FATAL ERROR: Could not obtain valid license authorization.
Total of -0.65 cpu second(s), 158608 maximum memory.
Received exception: SIGSEGV (segmentation violation)


Anybody can help please?

Jacques September 9, 2009 10:08

Quote:

Originally Posted by Mir5 (Post 213474)

But i have the following error :


/Fluent.Inc/license/lnamd64/fluentlm-helper91: no such file

No error handler available
....

Anybody could solve the problem?
Thanks for your help!

Autumn November 23, 2009 13:56

I have had the same problems and errors with 'fluentlm-helper90' and 'fluentlm-helper91' while trying to get Fluent 6.3 and Gambit 2.4 running on a 64 bit machine running Fedora 12.

My friend has just found the reason for this! :cool: It is because something in the 64-bit version of Fluent is still linked to 32-bit libraries. In Fedora 12 we had to install glibc.i686 -- the 32 bit version in addition to the 64-bit glibc that comes default with Fedora. This link has a bit more specific info of what we had to install http://osdir.com/ml/fedora-test-list.../msg00944.html. :p

quentin.deradigues April 19, 2010 05:42

Hello,

I've got the same problem as Manfred. When I do:

sudo apt-get install libstdc++5

I have an error: impossible to find package libstdc++5. It is possibly no longer available. Does anyone have an idea?

Thank you!

livera November 20, 2010 19:19

I installed 64-bit version of FLUENT and I am using MINT 10. When I run the program I faced with the following problem.
"/Fluent.Inc/license/lnamd64/fluentlm-helper91: no such file or directory

No error handler available"

Is there anybody solves this problem.

Thanks

Mojtaba.a March 23, 2013 08:47

Quote:

Originally Posted by livera (Post 284242)
I installed 64-bit version of FLUENT and I am using MINT 10. When I run the program I faced with the following problem.
"/Fluent.Inc/license/lnamd64/fluentlm-helper91: no such file or directory

No error handler available"

Is there anybody solves this problem.

Thanks

I am using Ubuntu 12.10, installing ia32-libs did the trick,
sudo apt-get install ia32-libs

Good luck


All times are GMT -4. The time now is 05:23.